Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Problem with CSS in IE 7/8

    I am currently working an a small website. It looks fine in IE 9, but in IE 7/8 the css isn't working. Im looking for some help in trying to get it to work.

    Good:
    http://imageshack.us/photo/my-images/43/goodlb.png/

    Bad:
    http://imageshack.us/photo/my-images/716/badel.png/

    CSS:
    Code:
    /*-------------------tag styling--------------------*/
    
    body { font-size: 24px;
          color: #003399;
    	  background-color: #66CCFF;
    	}
    
    header { padding: 10px;
          }
    	  
    nav { width: 150px;
         text-align: left;
    	 float: left;
    	 margin: 20px 0px;
    	 padding: 20px 10px;
    	 border: 1px solid black;
    	}
    	
    nav a { display: block;
          text-decoration: none;
    	  color: #003399;
    	  padding: 5px 0px;
         }
    	
    footer { clear: left;
           text-align: center;
    	   font-size: 20px;
    	   padding: 10px 10px;
          }
    	  
    h3 { font-size: 28px;
       }
    	
    	
    /*-------------------id styling---------------------*/
    
    #wrapper { width: 960px;
               margin-left: auto;
    		   margin-right: auto;
    		   background-color: #FFE6B2;
    		 }
    		 
    #logo { font-size: 42px;
            text-align: center;
    	  }
    	  
    #content { width: 700px;
    		  float: left;
    		  margin: 20px 15px;
    		  padding: 20px 15px;
    		  border: 1px solid black;
    		 }
    		  
    	  
    	  
    /*-------------------class styling------------------*/
    
    .indent { text-indent: 25px;
            }
    		
    .center { text-align: center;
             }

  • #2
    Regular Coder Candygirl's Avatar
    Join Date
    Apr 2008
    Location
    Switzerland
    Posts
    184
    Thanks
    3
    Thanked 56 Times in 56 Posts
    Hello,

    Apparently you use html5 tags that are not natively supported by IE8 (header, nav,...). That could be a reason. You can use some script to get them working on older browsers or you can use older html tags.
    "Imagination was given to man to compensate for what he is not;
    a sense of humour to console him for what he is."
    -Francis Bacon

  • #3
    New to the CF scene
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you! That did the trick.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •