Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Aug 2012
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    IE8 makes problems with the submenu. Anyone knows why?

    Dear folks,

    here is my site: http://horyzon.de

    It works perfectly fine on every browser. Except with IE8.

    The submenu just does not work properly. Could anyone spare a second and give it a look?

    If you click on any site, then the submenu works again. But if you are at the home site, the submenu will not work.

    Anyone knows where the problem is?

    thx.
    George

  • #2
    Senior Coder
    Join Date
    Apr 2011
    Location
    London, England
    Posts
    2,120
    Thanks
    15
    Thanked 354 Times in 353 Posts
    There should be no space at all before the DOCTYPE declaration, although this probably isn't the cause of your problem.

    But the DOCTYPE declaration is wrong:

    This document uses an inconsistent DOCTYPE declaration. The System Identifier http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd declares the XHTML 1.0 Strict document type, but the associated Public Identifier -//W3C//DTD XHTML 1.0 strict//EN does not match this document type.

    The recommended Public Identifier for http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd is -//W3C//DTD XHTML 1.0 Strict//EN.
    This can cause IE to go into quirks mode.

    You could also correct the following:
    id "text" is used twice;
    there is no longer an align attribute (line 147).

    HTML Validator
    "I'm here to save your life. But if I'm going to do that, I'll need total uninanonynymity." Me Myself & Irene.
    Validate your HTML and CSS

  • Users who have thanked AndrewGSW for this post:

    george101 (08-04-2012)

  • #3
    New to the CF scene
    Join Date
    Aug 2012
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thank you.

    I corrected every mistake. Here is the new Html Validation.

    Nevertheless the problem is not solved. I am up to any suggestion.

  • #4
    New to the CF scene
    Join Date
    Aug 2012
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Anyone? Any idea?

  • #5
    Senior Coder
    Join Date
    Apr 2011
    Location
    London, England
    Posts
    2,120
    Thanks
    15
    Thanked 354 Times in 353 Posts
    Quote Originally Posted by george101 View Post
    Anyone? Any idea?
    Your site is not opening at the moment.
    "I'm here to save your life. But if I'm going to do that, I'll need total uninanonynymity." Me Myself & Irene.
    Validate your HTML and CSS


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •