Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Jul 2012
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    image wrap in IE9

    Hi,

    I have an issue that appears in IE9, but not in Firefox. I have an image which is part of a table. It has a onmouseover applied to as well as being a link to a lightbox slideshow. The image appears to wrap itself around the bottom when displayed in IE9

    A snippet of the code is shown below:

    Code:
    <TABLE width="939" height="139" border="0" cellspacing="0" cellpadding="0" vAlign=top align="center">
    <TR>
    	<TD  background ="1cl.gif" width="61" height="139" BORDER="0" vAlign=top >
    	</TD>
    
    	<TD width="141" height="139" background="art.gif" 	vAlign=top onclick="dhtmlHistory.add('location1',	{message: 'backbox'});countdown()">
    
    	<P><A onmouseover="filter('e','image5a')" 	onmouseout="filter('e','image5')" href="Lady B&W.gif" 	rel="lightbox[slide]">
    	<IMG 	border=0 name=e src="http://www.justin-slater-		photography.com/art.gif" width=141 height=139>	</A>
    		
    		<a href="Lady B&W.gif" rel="lightbox[slide]" 			title="Dros Ryddid">	
    		</a>
    		<a href="Colours.gif" rel="lightbox[slide]" 			title="Colours">
    		</a>			
    		<a href="Night Oak.gif" rel="lightbox[slide]" 			title="Night Oak">
    		</a>	
    		<a href="Port.gif" rel="lightbox[slide]" 				title="Port">
    		</a>	
    		<a href="Pylon.gif" rel="lightbox[slide]" 				title="Pylon">	
    		</a>
    		<a href="light.gif" rel="lightbox[slide]" 				title="Autumn Rays">
    		</a>
    		<a href="Curve.gif" rel="lightbox[slide]" 				title="Curve">
    		</a>
    		<a href="Lady.gif" rel="lightbox[slide]" 				title="Dros Ryddid">
    		</a>
    		<a href="Hafod Sky.gif" rel="lightbox[slide]" 			title="Hafod Sky">
    		</a>
    		<a href="Spiral.gif" rel="lightbox[slide]" 				title="Spiral">
    		</a>
    		<a href="waxone1.gif" rel="lightbox[slide]" 			title="Wax">
    		</a>
    		<a href="Draig.gif" rel="lightbox[slide]" 				title="Draig">
    		</a>
    		<a href="Colour Shape.gif" rel="lightbox[slide]" 			title="Colour Shape">
    		</a>
    		<a href="Cab.gif" rel="lightbox[slide]" 				title="Cab">
    		</a>
    		<a href="Orange.gif" rel="lightbox[slide]" 				title="Orange">
    		</a>
    		<a href="Cannon Light.gif" rel="lightbox[slide]" title="Cannon Light">
    		</a>
    		<a href="Colour Block.gif" rel="lightbox[slide]" title="Pillar">
    		</a>
    		<a href="Apple.gif" rel="lightbox[slide]"				title="Afal">
    		</a>
    	</p>
    	</TD>
    Sorry if my code is appears all over the shop !

  • #2
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,955
    Thanks
    9
    Thanked 726 Times in 720 Posts
    Not very easy without seeing the images and the css.
    Can you give a link to your page?

  • Users who have thanked SB65 for this post:

    homph (07-19-2012)

  • #3
    New to the CF scene
    Join Date
    Jul 2012
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts
    HI,

    Here's a link to my page :

    http://www.justin-slater-photography.com/Galleries.html

    Many thanks for your help

  • #4
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,955
    Thanks
    9
    Thanked 726 Times in 720 Posts
    I can't immediately see an issue in IE9 - which image is the problem?

  • #5
    Registered User
    Join Date
    Jun 2011
    Posts
    1,063
    Thanks
    12
    Thanked 241 Times in 240 Posts
    I believe he is referring to this:

    Internet Explorer:


    I spent 30 minutes trying to understand this using the god awful Internet Explorer inspect element and my head finally exploded.

    What I've learned about the problem is that the repeating itself is probably due to JavaScript? but can be fixed using overflow: hidden; and setting the inline elements to display: block;. I personally was unable to find the solution quickly and the tables and inline styles are messing with my head, so I'm going to have to move on.

    Sammy12

    P.S. The problem is also seen in Firefox

    Firefox:


    Chrome:
    Last edited by Sammy12; 07-20-2012 at 10:10 PM.

  • #6
    Regular Coder
    Join Date
    Jul 2012
    Location
    London
    Posts
    473
    Thanks
    4
    Thanked 86 Times in 86 Posts
    @Sammy

    I fixed the issue for him, via pm.

    Issue: Table using body background - margin issue.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •