Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Jan 2011
    Posts
    302
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Utah doesn' display properly IE9

    http://www.countyfairgrounds.net/utah/utah.php

    I am having a severe problem getting this page to display right - it looks different in Chrome then in IE9 and I don't know why - it will not validate in the html5 W3C validator either. However the css3 is validating. I am getting some kind of weird error on line 810 in the html5 validator as to why this page cannot be checked. It is the only one of my state pages giving me this and I am confused. Nor can I get the search box on the the page upper right - like it is on all our other state pages. I have replaced the doc types and now I don't know what to do. Help please

  • #2
    Regular Coder
    Join Date
    Jun 2002
    Location
    Flint, Michigan, USA
    Posts
    623
    Thanks
    1
    Thanked 20 Times in 20 Posts
    I tried it and got the same error. Try comparing the Utah and Ohio pages and look for a difference. Hopefully, that code will then be obvious and you can fix it.

  • #3
    Regular Coder
    Join Date
    Aug 2005
    Location
    MS
    Posts
    832
    Thanks
    10
    Thanked 79 Times in 77 Posts
    Fix the CSS 2.1 errors.

    The errors for HTML are invalid HTML characters. probably your have a web editor that is not giving you compliant HTML coding. You must specify a character set meta tag for your page. [ The error was: utf8 "\x92" does not map to Unicode ] The apostrophe here produced a question mark because it couldn't decode it: region�s That happens on some none web editors.

    HTML Tidy flagged:

    Result: 52 errors / 3 warnings

    Info: W3c Online Validation

    line 423 column 66 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 423 column 75 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 423 column 83 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 423 column 92 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 429 column 9 - Error: End tag figure seen, but there were open elements.
    line 427 column 29 - Error: Unclosed element section.
    line 610 column 149 - Error: Bad value 290px for attribute width on element iframe: Expected a digit but saw p instead.
    line 610 column 149 - Error: Bad value 163px for attribute height on element iframe: Expected a digit but saw p instead.
    line 610 column 149 - Error: The frameborder attribute on the iframe element is obsolete. Use CSS instead.
    line 620 column 67 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 620 column 76 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 620 column 83 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 620 column 92 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 633 column 66 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 633 column 75 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 633 column 83 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 633 column 92 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 633 column 200 - Warning: The border attribute is obsolete. Consider specifying img { border: 0; } in CSS instead.
    line 656 column 57 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 656 column 63 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 658 column 25 - Error: Element style not allowed as child of element div in this context. (Suppressing further errors from this subtree.)
    line 668 column 25 - Error: Element style not allowed as child of element div in this context. (Suppressing further errors from this subtree.)
    line 672 column 25 - Error: Element style not allowed as child of element div in this context. (Suppressing further errors from this subtree.)
    line 712 column 70 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 712 column 83 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 720 column 6 - Error: End tag div seen, but there were open elements.
    line 453 column 11 - Error: Unclosed element aside.
    line 723 column 8 - Error: Stray end tag aside.
    line 1012 column 47 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1012 column 65 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 31 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 37 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 45 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 51 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 57 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 65 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 68 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 71 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 76 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 81 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1225 column 85 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 31 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 37 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 45 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 51 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 57 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 65 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 68 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 71 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 76 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 81 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1229 column 85 - Error: & did not start a character reference. (& probably should have been escaped as &.)
    line 1243 column 7 - Error: Stray end tag div.
    Last edited by Major Payne; 06-18-2012 at 09:16 AM.
    ☠ ☠RON☠ ☠

  • #4
    Regular Coder
    Join Date
    Jan 2011
    Posts
    302
    Thanks
    7
    Thanked 0 Times in 0 Posts
    thanks for the reply
    can you enlighten me a little more on this "character set meta tag for your page"
    I of course know what meta tags are. We do use them - the php is created in a different editor by a different person, can I fix this in the Meta tags?
    Cause these weird charactes are on all of our pages. Any help would be appreciated


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •