Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Jun 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IE 9 only formatting issues

    Greetings all,

    I have a site that looks good on all browsers except IE 9. It looks good on chrome, opera, firefox, etc. It even looks good in IE 8 and 7. But with IE 9 divs are shifted and the page is broken. Try the following URL in IE 9 and you'll see that the right container is shifted to the bottom.

    http://www.doc4uninsured.org/?locati...-Center-Dental

    Try the same URL on other browsers and it should be OK. I"m using jquery in inject html into dom.

    Anyone have any idea why it looks bad on IE 9? Thank you in advance for any input.

  • #2
    Regular Coder COBOLdinosaur's Avatar
    Join Date
    Jul 2002
    Location
    Canada
    Posts
    404
    Thanks
    2
    Thanked 32 Times in 32 Posts
    E 9 is in quirksmode. Use a strict doctype like

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">

    or

    <!doctype html>
    <html lang="en">
    <head>
    <meta charset="utf-8">
    <meta content="IE=edge,chrome=1" />

    No offense, but IMO that is a very low quality page. It is the kind of site I visit once and then block. It is bloated, excessively
    scripted, and far too agressive with browser resources. I suspect it crashes and hangs the browsers of a lot of users who are on
    slow connections or older underpowered machines.
    100% standards compliant code is 100% correct 100% of the time.
    one of my toys from my repository and perhaps some help getting help

    Cd&

  • #3
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,955
    Thanks
    9
    Thanked 726 Times in 720 Posts
    I have to confess I read the previous post and thought "Well, it can't really be that bad, can it...?".

    The validator brings up 9797 errors. Be warned, the validator page takes a long time to load.

    I doubt very much whether just changing the doctype will make much difference. IE is in quirksmode (can't check in IE myself because it crashes) because of some of those many errors, I'm afraid.

    Sorry....

  • #4
    New to the CF scene
    Join Date
    Jun 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Solved

    Solved. One of my affiliates had a simple html form in the page and, as the result, the page was broken in IE 9. I removed the form and it's fixed. How and why...only a higher power knows

    Thanks all!


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •