Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 1 of 1

Thread: Iframes

  1. #1
    New to the CF scene
    Join Date
    Apr 2012
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Iframes

    Hello.
    I am having a problem with iframes. Just starting to learn this feat, so I apologize for any apparent code-idiocy.

    Here's a screenshot:


    And the code I deem important for the problem:
    <asp:ContentPlaceHolder ID="MainContent" runat="server"/>
    <!--- Menu --->
    <iframe id="menu" name="menuWindow" src="menu.aspx" height="224px" width="113px" frameborder="0" scrolling="no" ></iframe>
    <iframe id="main" name="mainContent" src="default.aspx" height="640px" width="672px" frameborder="0" scrolling="no" ></iframe>

    The menu.aspx:
    <asp:Content ID="Content2" ContentPlaceHolderID="MainContent" Runat="Server">
    <a id= "menuNews" href="default.aspx" target="mainContent"></a>
    <a id= "menuInfo" href="info.aspx" target="mainContent"></a>
    <a id= "menuContact" href="contact.aspx" target="mainContent"></a>
    <a id= "menuLinks" href="links.aspx" target="mainContent"></a>
    </asp:Content>

    The relevant CSS:
    #main
    {
    background-image:url("../graphic/content.png");
    height:640px;
    width:672px;
    position:absolute;
    left:25%;
    top:30%;
    }

    #menu
    {
    position:absolute;
    top:30%;
    left:15%;
    }


    My question is, why does it keep copying itself and why isn't the default.aspx not showing.
    Furthermore, when I click a link they are showed in the menu iframe and not the target I defined.

    Thanks in advance,
    Mowinckel
    Last edited by Mowinckel; 04-20-2012 at 11:17 AM.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •