Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Rollover images with CSS

    Hi,

    I have three images (for cart, search and fax) in the left column navigator.

    When I hover with the mouse over them, the background image is supposed to change position. I used the pixy method. All works well with all browsers ... except IE. In IE the hover state is shown, when the mouse is not hovering over the image.

    I have tried endless hours, and at one point even got it to work. But then the line-heights needed tweaking, and after doing that, the roll over no longer worked. I tried, but I couldn't retrace my steps.

    Could someone help me with that?

    The link is http://www.segufixshop.eu/detail.php?recordID=1.php

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,668
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Hello roxana,
    It seems to work fine on this end. I looked at the site in FF11, IE9, IE8 and IE7. All seem to behave the same...unless I've misunderstood the question.

    There are plenty of errors found by the validator that should be fixed. Especially the lack of DocType. See the links about DocTypes and Validation in my signature line.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you for helping.

    Honestly, I don't know what just happened. Without changing it, it simply worked again. But also the line heights in IE8 and IE9 need adjusting again. I will try to get that, but not without backing up the working version first

    The errors the validator found, is that a problem? I am not a coder, so I never took the time to look into that. I am just glad, when things work out.

  • #4
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,668
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Quote Originally Posted by roxana View Post

    The errors the validator found, is that a problem? I am not a coder, so I never took the time to look into that. I am just glad, when things work out.
    Some are more of a problem than others. Without a DocType, IE is in quirksmode and that can cause unpredictable problems all over the place. Did you read the article on DocTypes? It's an important thing to know about and use.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #5
    New to the CF scene
    Join Date
    Feb 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I ran into problems with the doc type once, where the browser would not display some European characters correctly. I thought I had taken care of that.

    I will read the links in your signature and work at validating the site.

    Thank you for pointing that out.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •