Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Jan 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy IE HTML Rendering Issues

    Can anyone expain to me why this page I am working on looks fine in both Google Chrome and Mozilla Firefox, but looks completely askew when using Microsoft Internet Explorer?

    Any help would be appreciated!

    http://imxevent.com/imx2011/Public/C...ortMenu=101005

    view-source:http://imxevent.com/imx2011/Public/C...ortMenu=101005

    I think it is this piece of code that is causing me problems (lines 281-287)...


    <p><font style="FONT-SIZE: 20px" color="#c00000"><strong>imX Keynote Sessions</strong></font></p>

    <p><span style="FONT-FAMILY: Univers 57 Condensed; COLOR: black"><font style="FONT-SIZE: 15px">An extension of the forward thinking that has defined the development of imX, these Keynote Presentations reflect imXs position as a high-level gathering place for manufacturing thought leaders from across the country and around the world. If its important for U.S. manufacturing, it's discussed at imX.</font></span>&nbsp;</p><p><table style="width: 510px; height: 138px; " class="RadEDomMouseOver">

    <tbody>

    <tr>

    <td colspan="3">&nbsp;<strong>KEYNOTE SESSION&nbsp;- DAY ONE</strong></td></tr>

    <tr><td style="text-align: center; vertical-align: top; ">&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;<img alt="Michael Molnar" src="http://www.imxevent.com/imx2011/CUSTOM/images/molnar.jpg"&gt;&amp;nbsp;&lt;/td&gt;&lt;td&gt;&amp;nbsp;&lt;/td&gt;&lt;td style="text-align: left; vertical-align: middle; "><font><font><br><url=http://www.imxevent.com/imx2011/public/Content.aspx?ID=316&amp;amp;sortMenu=102003 style="color: rgb(255, 0, 0); font-family: arial, Verdana, sans-serif; font-size: 14px; font-weight: bold; ">Michael F. Molnar</a></font></font><b style="font-family: arial, Verdana, sans-serif; font-size: 14px; ">, FSME, CMfgE, PE</b><br><br><table class="RadEDomMouseOver" style="font-family: arial, Verdana, sans-serif; font-size: 14px; font-weight: bold; width: 510px; height: 138px; "><tbody><tr><td style="text-align: left; vertical-align: top; "><strong><font color="#ff0000">Date:</font></strong></td><td>&nbsp;</td><td style="text-align: left; vertical-align: top; ">Monday, September 12, 2011</td></tr><tr><td style="text-align: left; vertical-align: top; "><strong><font color="#ff0000">Speaker:</font></strong></td><td>&nbsp;</td><td style="text-align: left; vertical-align: top; ">Michael F. Molnar, FSME, CMfgE, PE</td></tr><tr><td style="text-align: left; vertical-align: top; "><strong><font color="#ff0000">Title:</font></strong></td><td>&nbsp;</td><td style="text-align: left; vertical-align: top; ">The U.S. Advanced Manufacturing Initiative: <br>Your Role in Public Private Partnerships</td></tr></tbody></table></td></tr><tr><td style="TEXT-ALIGN: left; VERTICAL-ALIGN: top" colspan="3">&nbsp;<iframe width="480" height="315" src="http://www.youtube.com/embed/VUzBbwlpIFk" frameborder="0" allowfullscreen=""></iframe></td></tr></tbody></table></p>

    <p><a name="schutz"></a>
    Attached Thumbnails Attached Thumbnails IE HTML Rendering Issues-webpagecodinghelp.png  

  • #2
    Senior Coder
    Join Date
    Aug 2010
    Location
    High Point, NC
    Posts
    3,332
    Thanks
    5
    Thanked 363 Times in 360 Posts
    The 97 coding errors may have some part in it. IE doesnt like invalid code. You can view them here.
    Teed

  • #3
    New to the CF scene
    Join Date
    Jan 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    well, the code looks seriously f'd. I was just using the WYSISYG that came with the site. Was it because I was using Google Chrome and cutting and pasting from there (apple-span tags are my nemisis)? Any ideas on where to start cleaning this sht up? Thanks for report link btw.

  • #4
    Senior Coder
    Join Date
    Aug 2010
    Location
    High Point, NC
    Posts
    3,332
    Thanks
    5
    Thanked 363 Times in 360 Posts
    Quote Originally Posted by Ninjacob View Post
    well, the code looks seriously f'd. I was just using the WYSISYG that came with the site. Was it because I was using Google Chrome and cutting and pasting from there (apple-span tags are my nemisis)? Any ideas on where to start cleaning this sht up? Thanks for report link btw.
    The majority of them seem to be missing alt attributes and encoding html entities, which wont break your layout. But, some of the more serious ones and missing closing tags and such. I would start with any of them that mention you didnt close a <p> tag or whatever tag the validator says.

    Some of the first ones are improperly self closing meta tags. Usually each error explains how to fix it, but if you have trouble with one, just post back here.

    You'll find that since the errors are hierarchical in nature, you can fix one and clear up several, or you might fix one and it shows more.
    Teed

  • #5
    New to the CF scene
    Join Date
    Jan 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks Teed! I will let you know how it shakes out. Only 97 errors, piece of cake

  • #6
    New to the CF scene
    Join Date
    Jan 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    it's all good. My table width's were just a little askew. Thanks for the help!


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •