Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Dec 2011
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Div disappears in IE8 on hover over other elements

    Hi there,

    I am having a strange problem which only shows up in IE8 (or IE9 in Compatibility Mode.)

    The page http://ericplumb.dreamhosters.com/cm...rative-colitis ought to have a grid of white squares underneath the lower gray bar ("13 categories"). Its id is "#subclusters", and it shows up fine in FF or Chrome but doesn't load in IE8.

    I can get it to show up by setting any CSS property on it (even an innocuous one like margin: 1px) using a Javascript onload or the IE developer tools, but as soon as I hover over any of the element with a :hover selector (Questions & Answers, Treatment Options Overview, 13 Categories) it disappears again. If it weren't for this oddity I would accept the Javascript hack and move on.

    I've searched around the Web to find a solution but all the IE bugs related to disappearing elements seem to be related to position: absolute or hasLayout, nothing on an element disappering on hover over another element.

    Any suggestions are appreciated.

    Thanks much,
    Eric

  • #2
    Registered User
    Join Date
    Jun 2011
    Posts
    1,063
    Thanks
    12
    Thanked 241 Times in 240 Posts
    Welcome to the forums xylem!

    On my computer, the blocks show up fine in ie8, however they disappear after a while for some reason. I would say it really doesn't matter, but my only suggestion would be to try and set a width in px to the td's instead of %. You could also try testing without using :first-child (you had margin-left: 0). Also take note that padding: 20px; on the td isn't working in ie8. I'm pretty sure cellpadding: ; is still recommended, though I don't use tables myself. I think if you didn't use tables for these, you wouldn't have a problem.


    sorry, that's all I got,
    Sammy12

  • Users who have thanked Sammy12 for this post:

    xylem (12-21-2011)

  • #3
    New to the CF scene
    Join Date
    Dec 2011
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks Sammy. Switching from tables did the trick.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •