Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Dec 2011
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Site won't load in Safari

    This problem is driving me totally insane. So far nobody has been able to solve it. Anybody who can is automatically my best friend for life.

    THE PROBLEM:

    My portfolio website loads *extremely* slowly in Safari. Only Safari. Safari on every single computer, iPhone, iPad, and iPod I have tried.

    Strangely enough, the problem seems to be contained SOLELY to my host's server. When I upload my site files to a server hosted by a different company, Safari loads the site fine.

    Here are some images to show you what I'm dealing with.


    The site loading in Safari on my current server: http://maxigumee.com/HOSTONY_IMAGE.jpg


    The site loading in Safari on a *different* server (it's totally fine): http://maxigumee.com/godaddy_image.jpg



    Here is my *actual* website file: http://maxwelltielman.com

    Just to clarify— I have already gone through the steps of validating the HTML *and* stripped the site completely of CSS and extraneous code so that *only* the images were displayed. The problem still persisted.

    The problem occurs whenever I visit my site for the first time on a computer, reload the website, or empty the cache.

    I've e-mailed my host numerous times about this and they have been nothing but useless on the matter. They have informed me that the site loads fine in Firefox (not helpful) and that their server is fine.

    What should I doooo? I'm on the verge of ripping my hair out in frustration.

  • #2
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,662
    Thanks
    6
    Thanked 1,006 Times in 979 Posts
    OK, I see it, too. I can’t exactly say what it is right now but using the Net panel of Safari’s built in debugging tool (accessible with keyboard shortcut Cmd+Option+I) I can see that these small images at the right in the “Recent works” section take a long time to load. And this is partly because they are way too big (in terms of file size) for their size (in terms of dimensions). You really need to optimize your images for the web. An image like inthewild.jpg should be like 3–4 KB, not 27.

    You also have a lot of useless images that add no value to your site but add pageload, like the bottom2, 4, and 6 JPEGs and the ridiculous width of the contact/copyright image, most of which just consists of white space. Likewise, these horizontal double border images are a total waste of bandwidth. This could be a 1px wide background image that is repeated horizontally.

    Fixing these issues might already speed up your site tremendously.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •