Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New Coder
    Join Date
    Oct 2011
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts

    NIVO Slider Issue

    Hello all,

    Slider works in Mozilla but not in IE. Thoughts?

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,667
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Hello OdyOwnage,
    I think IE sucks. To know why your slider doesn't work though, you would need to provide a lot more information...like a link to the test site or so actual code.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    New Coder
    Join Date
    Oct 2011
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Excavator,

    I am going to totally agree with you that IE sucks. I'll post the code when I get home.

  • #4
    New Coder
    Join Date
    Oct 2011
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts
    HTML:

    Code:
    <html>
    <head>
    
            <link rel="stylesheet" href="/v/vspfiles/assets/images/style.css">
    	<script type="text/javascript" src="/v/vspfiles/assets/images/jquery.js"></script>
    	<script type="text/javascript" src="/v/vspfiles/assets/images/jslider.js"></script>
    	
    	<script type= "text/javascript">
    		$(function() {
    			$(".slider").jslider({
    				btnNext: ".next",
    				btnPrev: ".prev"
    			})
    		});
    	</script>
    
    </head>
    <body>
    
    <center><div id="container">
    	<img id="prev" class="prev" src="/v/vspfiles/assets/images/prev.png" /><img id="next" class="next" src="/v/vspfiles/assets/images/next.png" />
    	<div class="slider">
    		<ul>
    			<li><img class="slider" src="/v/vspfiles/assets/images/nemo.png" alt="Image 1" /></li>
    			<li><img class="slider" src="/v/vspfiles/assets/images/walle.png" alt="Image 2" /></li>
    		</ul>
    	</div>
    </div></center>
    
    </body>
    </html>
    CSS:

    Code:
    body {
    	width:800px;
    	margin:0 auto;
    	background-color:FFFFFF;
    }
    
    #container {
    	position:relative;
    	margin-left:50px;
    	margin-right:50px;
    	margin-top:50px;
    	width:700px;
    }
    
    #prev {
    	position:absolute;
    	top:75px;
    	left:-70px;
    	z-index:10;
    }
    
    #next {
    	position:absolute;
    	top:70px;
    	right:-75px;
    	z-index:10;
    }
    
    .slider {
    	width:700px;
    	height:250px;
    	border:8px solid #000;
    }

  • #5
    New to the CF scene
    Join Date
    Oct 2011
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Can you post a link to the page and we can check it out for you?

  • #6
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,667
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    To start with, have a look at the link about DocTypes in my signature line. You really need to have a DocType!
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #7
    New Coder
    Join Date
    Oct 2011
    Posts
    25
    Thanks
    3
    Thanked 0 Times in 0 Posts
    NVM, it works now...? Strange LOL!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •