Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Regular Coder
    Join Date
    Jul 2011
    Posts
    140
    Thanks
    8
    Thanked 0 Times in 0 Posts

    stylesheet help, not functioning

    I don't know whats wrong, not displaying images at all

    CSS CODE
    Code:
    p.accountsummary {
    background-image: url('../includes/image/accountsummary.jp…
    position: relative;
    top: 50 px;
    }
    
    #header {
    background-image: url('../includes/image/header.jpg');
    width: 1000px;
    height: 45 px;
    
    
    }

    HTML CODE

    Code:
    <div id="header">
    
    </div>
    
    <div class= "account summary">
    </div>

  • #2
    Senior Coder
    Join Date
    Aug 2010
    Location
    High Point, NC
    Posts
    3,332
    Thanks
    5
    Thanked 363 Times in 360 Posts
    Do you really have a space in your div class name?

    <div class= "account summary">

    You dont have one in your stylerule.
    Teed

  • #3
    Regular Coder
    Join Date
    Jul 2011
    Posts
    140
    Thanks
    8
    Thanked 0 Times in 0 Posts
    sorry that was just a typo in the post, my actual code does not have a space. Any other ideas as to why this is not working?

  • #4
    Regular Coder
    Join Date
    Aug 2011
    Location
    U.S.A.
    Posts
    233
    Thanks
    2
    Thanked 48 Times in 48 Posts
    Your height's have spaces in them. They should not.
    Your accountsummary id is assigned to a div, not a p as in your code.

    Is the CSS file embedded in the html file itself, or linked to it?
    If linked, is it in the same folder?
    What is the folder structure of your site? you are using relative links to find the images, so in your css, you are saying "Go up one folder level, then go to the includes folder etc.". If you CSS file is in the same folder as the includes folder is, then you don't need the "../" part.

  • #5
    Regular Coder
    Join Date
    Jul 2011
    Posts
    140
    Thanks
    8
    Thanked 0 Times in 0 Posts
    ok i did the necessary changes still not working
    File paths:

    development.mysite.com/load/include/css/style.css
    development.mysite.com/load/account.php


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •