Hi--

I have an interactive quiz on my site that loads from an online quiz-maker (quizrevolution.com). The problem is that the quiz does not load all the way in Firefox: it loads everything but the "start" button.

The people at quizrevoution.com tell me that the "start" button uses javascript to load, but I am totally at a loss why Firefox won't let the "start" button load completely. I have tested this on both Mac and Windows machines, and the problem is there, but only with Firefox.

My site is at http://www.ABCsofUFOs.com

If you click on the "TEST YOUR KNOWLEDGE ABOUT UFOs" link at the bottom left of the page, you will see the quiz.

And here is the code for the part of the html page where I embed the quiz itself. Any help at all would be really terrific. A premature many thanks!!!!

[HTML]<!--QUIZ BEGINS-->

<article id="page_7c">
<div class="box" id="page1">
<a href="#page_1" class="close"></a>
<div class="wrapper pad_bot1">
<div class="grid_16 prefix_4">

<p></p>

<img style="visibility:hidden;width:0px;height:0px;" border=0 width=0 height=0 src="http://c.gigcount.com/wildfire/IMP/CXNID=2000002.0NXC/bT*xJmx*PTEzMTUzNDA1NTM1MjAmcHQ9MTMxNTM*MDU1NTUwMCZwPTIwNDMyMSZkPSZnPTEmbz*wMWFhMzNjMDI4ZWM*NjNmYTZh/NGU1M2FiNzRmZTZlMSZvZj*w.gif" /> <iframe src="http://www.quizrevolution.com/act147691/mini/go/test_your_knowledge_about_ufos" width="380" height="400" frameborder="0" scrolling="no" name="mystudiyoIframe" title="QuizRevolution.com"><a href="http://www.quizrevolution.com/act147691/mini/go/test_your_knowledge_about_ufos">test_your_knowledge_about_ufos</a></iframe>
<br><p class="color1">Can't see the "Start" button? Click on "spread the word"<br>and then click on "play again" (which will appear as a <br>play button on bottom right). Then wait...</p>

</div>
</div>
</div>
</article>