Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New Coder
    Join Date
    Jun 2011
    Posts
    80
    Thanks
    13
    Thanked 0 Times in 0 Posts

    Safari issue - checkboxes don't appear.

    Hi,

    Running Win7 64 bit with Safari 5.0.5 for Windows, my website does not display checkboxes. I can still click in the area where the box would normally be, and it would select as it should, but the box doesn't appear. Checkboxes appear in every other major browser. Since I'm not on a mac, I can't test if this works natively in Mac.

    Any ideas how to fix this? Thanks for reading.

  • #2
    Regular Coder
    Join Date
    Jul 2011
    Location
    India
    Posts
    496
    Thanks
    3
    Thanked 57 Times in 56 Posts
    Please share your website link or HTML and CSS code...


  • #3
    New to the CF scene
    Join Date
    Jul 2011
    Location
    India
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello friend thanks for sharing.

  • #4
    New Coder
    Join Date
    Jun 2011
    Posts
    80
    Thanks
    13
    Thanked 0 Times in 0 Posts
    The CSS:

    Code:
    body 
    {	
    	overflow-x:hidden;
    	font: 10px "Trebuchet MS";
    	background-color:#720000;
    }
    
    #tabs 
    {
    	width:105%;
    	margin: 0 left;
    	padding: 0px;
    }
    
    #tabs .ui-tabs-nav 
    {
    	text-align: center;
    	height: 33px;
    }
    
    #tabs .ui-tabs-nav li 
    {
    	display: inline-block;
    	float: none;
    	margin: -0.3em;
    }
    
    span.chk
    {
    	cursor:pointer;
    	text-decoration: none; 
    	color:#A90101; 
    	font-size:8pt;
    	font-family:"Verdana", Verdana, serif;
    }
    
    span.chk:hover 
    
    {
    	text-decoration: underline; 
    	color:#A90101;
    	font-size:8pt;
    	font-family:"Verdana", Verdana, serif;
    }

    The checkboxes:

    Code:
    <body>
    <table bgcolor="#DCDCDC">
    <tr><td>
    	<table bgcolor="#DCDCDC" cellspacing="5">
    	<tr><th colspan="11" align="left">
    	<a id="checkall"><span class="chk">Check All</span></a>&nbsp;&nbsp;&nbsp;
    	<a id="uncheckall"><span class="chk">Uncheck All</span></a>
    	</th></tr>
    	<tr align="center">
    	<form name="Types_form" action="#" method="POST">
    	<td><img src="images/icons/type0.png">
    	<br><input type="checkbox" class="checkbox" id="checkbox0" name="checkGroup[]"  value="chk-0"  /></td>
    	<td><img src="images/icons/type1.png">
    	<br><input type="checkbox" class="checkbox" id="checkbox1" name="checkGroup[]"  value="chk-1"  /></td>
    	<td><img src="images/icons/type2.png">
    	<br><input type="checkbox" class="checkbox" id="checkbox2" name="checkGroup[]"  value="chk-2"  /></td>
    	</form>
    	</tr>
    </table>
    </td>
    </tr>
    </table>
    </body>


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •