Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Jan 2011
    Posts
    302
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Featured problem html5

    Actually I have spent most of the day working out the code and css for this page
    http://www.countyfairgrounds.net/findanevent.php

    and I have a bad headache - so I am hoping someone here can tell me why in the upper division featured box (the one with the graphic hay behind it)
    there are vertical scroll bars - on the right BUT only in IE9

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Do you have any floats in that section? What is happening is the content inside of it is overflowing the height. Because you have overflow:auto you get the scrollbars. Try overflow:hidden; instead. Also just tried it in IE9. I see no scrollbars so I guess you may have fixed it.
    Last edited by _Aerospace_Eng_; 04-30-2011 at 04:18 AM.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    Senior Coder
    Join Date
    Aug 2010
    Location
    High Point, NC
    Posts
    3,333
    Thanks
    5
    Thanked 363 Times in 360 Posts
    Shows in IE8 as well. You have a style......display: inline-table; way down in one of your section divs that seems to be the cuplrit.
    Teed

  • #4
    Regular Coder
    Join Date
    Jan 2011
    Posts
    302
    Thanks
    7
    Thanked 0 Times in 0 Posts
    well fixing the overflow seemed to solve it. Would you please check in IE and see what you think? My idea of overflow:auto was that if there was stuff in the division that ovelfowed it the division would expand to accommodate . As far as I can tell nothing overflows. Nor did it before I changed auto to hidden.

    As for my table display tag affecting the feature division. It the display style is way down on the page and is in the content division, which is outside the #featured division where the problem was This whole section is code for the display of our MySQL - and believe me it was a nightmare


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •