Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Apr 2011
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Exclamation Background Image not working in IE8

    Hi There.

    I am busy making a nice image-rich contact form in dreamweaver. I am having display issues in ie8 as all of my background images are showing except for the one. These images look fine in firefox and chrome but for some reason this single image is not displaying in ie8.

    The URL for my post is www.winwithharley.co.za. Here is the code i have used:

    Code:
    <div class="name" style="background-image: url('images/email.png'); width:579px; height:66px;">
                                        <div class="textbox" style="top:40px !important;">
                                        	<input type="text" class="textboxstyle" name="email" id="email" />
                                        </div>
    I would appreciate any help you can give me.

    Regards
    Bo Bissict

  • #2
    New to the CF scene
    Join Date
    Apr 2011
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    just a quick note:

    i just opened it up in ie8 and the image was not showing. then if i refresh the page the image shows.

    hopefully this helps. looking forward to hearing any solutions

  • #3
    Regular Coder
    Join Date
    May 2010
    Location
    Bathurst, Australia
    Posts
    180
    Thanks
    1
    Thanked 22 Times in 22 Posts
    The code you have posted is correct. The code on your site is not. You have:
    Code:
    <div class="name" style="background-image:url(images/email.png); width:579px; height:66px;">
    You left out the quotation marks. Could be the cause. Also, What's with all the divs and breaking up the background image? You really only need to have two main divs there. One to pretty much hold that image, the other for your form. Is this how dreamweaver does things?
    Disclaimer: I'm hungover 70% of the time i'm on here, any information given may not be correct, or even legible.

  • Users who have thanked BulletTimeBill for this post:

    bobissict (04-05-2011)

  • #4
    New to the CF scene
    Join Date
    Apr 2011
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi BulletTimeBill

    Just made that change and it seems to be working. thank you so much for your help. unfortunately we were given this piece of html from the client with the divs already in place.

    If it continues not too work i shall take your advice and convert to just the 2 divs.

    Thanks again


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •