Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Nov 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Problem with table appearance in Firefox

    This is a problem I've unfortunately just noticed after the page has been in place for a couple months...possibly it was not noticeable on my desktop because of larger monitor & higher resolution compared to the laptop I'm using now. I made this table as I usually have in the past with no issues.

    http://www.nancychuang.com

    Fine in Safari and Chrome, and here's the kicker-- completely fine in Firefox when viewing the local file, so it's hard to see how to fix it. There was no real difference with that table and this one created a few years ago: http://www.weareonemalawi.org/home.html, which is still appearing correctly. Also did this one the same way: http://nancychuangphotography.com/ and no problems with the table there.

    But if you view nancychuang.com side-by-side with Chrome or Safari, you can see that all the images expand and a space between cells has been added. I revised the table height and width attributes to use CSS in case that made a difference (but considering the other sites and the local file appearance, it shouldn't), and oddly enough it worked...and then stopped working. Like, I uploaded the revised page, checked it, saw the improvement, closed it and checked the page again, and it reverted back to the way it was before.

    SO strange! And again, I cannot see the problem in Firefox viewing my local file so I don't know what any revisions do until I upload. Any help would be appreciated. I also tried clearing my cache a few times, so I don't think this is a problem that only I am seeing...

  • #2
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,955
    Thanks
    9
    Thanked 726 Times in 720 Posts
    Your page looks the same in Chrome and FF3 to me - there are no obvious gaps between the images.

  • #3
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,853
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    Any help would be appreciated.
    Don't you know why using tables for layout is very bad? You need to have a valid markup, to expect a compatible output.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #4
    New to the CF scene
    Join Date
    Nov 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I haven't done websites professionally in many years and admit to not really keeping up with the changes...I only do personal stuff anymore and haven't really looked into new markup. I do have a couple new non-personal projects to work on now though, so I definitely plan to study this!

    I'm baffled why it would only look different for me. Any thoughts on that? Using FF 3.6.12 for Mac. Like I said, I've cleared my cache multiple times and it is absolutely different when uploaded than it is when viewing the local file...

    Edit: oh dear god. I can't believe I've never tried hitting "reset" in FF view, even though I never zoom in or out yet it's appeared this way to me every time, with new tabs, new windows, not ones I've previously been viewing something in that might have possibly ever zoomed. Total idiot...now it's appearing fine.
    Last edited by openroad2010; 11-11-2010 at 03:22 PM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •