Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Nov 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Image map not working in IE (but works in firefox)?

    Hopefully someone can help me with this issue I'm having; an image map on my page does not work in IE (any version I've tried), but works fine in firefox. The code is:

    Code:
    <p><img src="filmstripnew.jpg" alt="" usemap="#filmstrip2" height="700"
    border="0" width="900"><map name="filmstrip2">
    &gt;</map>
    </p>
    <p><a href="index.html"><img src="home.jpg" alt="" height="52"
    border="0" width="126"></a></p>
    </div>
    <map name="filmstrip2">
    <area title="if ya got the time..." shape="rect"
    coords="214,638,718,670" href="reelfull.html"
    alt="if ya got the time...">
    <area title="for short attention spans..." shape="rect"
    coords="200,334,722,365" href="reelshort.html"
    alt="for short attention spans...">
    </map>

    I'm far from the best web developer in the world & I'm at a loss. Any suggestions would be much appreciated. Thanks in advance!

  • #2
    Regular Coder Kristofa's Avatar
    Join Date
    Jun 2009
    Location
    Leicester
    Posts
    143
    Thanks
    7
    Thanked 20 Times in 20 Posts
    Code:
    <map name="filmstrip2">
    &gt;</map>
    What's that bit about?

    I'm not 100% sure about the name attribute, but I think it needs to be unique on the page, like the 'id' attribute.

    Why do you have two <map> tags with that name anyway - what are you trying to do? Any chance of a link?

    That could be confusing IE...
    Learning along the way...

  • #3
    Senior Coder
    Join Date
    Aug 2010
    Location
    High Point, NC
    Posts
    3,338
    Thanks
    5
    Thanked 363 Times in 360 Posts
    Your link or the entire html and css code would help a great deal.

  • #4
    New to the CF scene
    Join Date
    Nov 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I changed some things around & it SEEMS to be working now, but it was really just guessing on my part...I generated this map with a program called X-Map and I'd like to know what it did wrong & what that one line is as well. Here is the full code for the page

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
      <meta http-equiv="content-type"
     content="text/html; charset=ISO-8859-1">
      <meta name="generator" content="Adobe GoLive 6">
      <title>Director Reel</title>
    </head>
    <body
     style="background-color: rgb(255, 255, 255); background-image: url(redbgrd.jpg);">
    <div align="center">
    <map name="filmstrip2">
    <area title="if ya got the time..." shape="rect"
     coords="214,638,718,670" href="reelfull.html"
     alt="if ya got the time...">
    <area title="for short attention spans..." shape="rect"
     coords="200,334,722,365" href="reelshort.html"
     alt="for short attention spans...">
    </map>
    
    <p><img src="filmstripnew.jpg" alt="" usemap="#filmstrip2" height="700"
     border="0" width="900"><map name="filmstrip2">
    &gt;</map>
    </p>
    <p><a href="index.html"><img src="home.jpg" alt="" height="52"
     border="0" width="126"></a></p>
    </div>
    </body>
    </html>
    here is the page link

    http://home.comcast.net/~dmdfilms2/reel.html

    thanks!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •