Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Question Chrome doesn't render the end-span correctly

    Hi,

    the main text-area of my forum-post-form doesn't render in Chrome (but works just fine in FF and IE).
    The form is located here:
    http://www.muzikum.eu/en/701-5/forum...ost_topic.html

    the problem lies in the hidden "BBCode Help"-span.

    More specifically in the fact that I use some li-tags without having them inside ul and /ul-tags.


    When I add those the list-icons (the dots in front of every li) dissapear (due to css-formatting).

    I'm a noob in css (my design is based upon a free template which I've adapted for my own use, but I'll never really master css I'm afraid).


    I want to keep the list-icons but without having to alter every other list in my mainconent-div.

    Any help is greatly appreciated

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,851
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    Start with fixing the errors in your markup, see http://validator.w3.org/check?verbos...ost_topic.html
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #3
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    wow. Last time I did it (and passed!) was in 2005. Guess I know what to do next
    But my problem isn't related with validation. I know it's because I don't put the li-items between a ul- and /ul. I simply need some help with my CSS.

    If I put it between the ul-tags, it won't show the bullets anymore. That's normal since in my CSS there's a line that removes the formatting from li's in the main content DIV. (as it should since I use several ul's). If I make a new class in which I define a list-style (eg ul.test {list-style:disc;} it still doesn't render the bullets. And my css skills aren't good enough to fix this.

  • #4
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    OFFTOPIC: Dude, almost 12 000 posts in 3 years! That's huge )

  • #5
    Senior Coder
    Join Date
    Aug 2010
    Location
    High Point, NC
    Posts
    3,335
    Thanks
    5
    Thanked 363 Times in 360 Posts
    I think there's only two reason I can think of that your list bullets dont show. One is if you dont have enough space to the left of the list. The bullets might be "covered" by the div beside it. Another reason of course would be if you have created a style rule to get rid of the bullets somewhere. ie

    li {list-style-type: none;}

    Also, coding lists without having them inside either an unordered list or an ordered list is not good and will probably always generate errors in validation.

  • #6
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,851
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #7
    New to the CF scene
    Join Date
    Jul 2010
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    well, I guess what to do than

    But fixing the code is not going to fix my problem. Putting my LI-tags between UL and /UL-tags will. But that gives me a new problem: in the css there's a definition "li {list-style=nothing}" for the LI's in the main content div.

    So as soon as I add the ul-tags my bullets will dissapear.... I can't change the main content li-style since there are quite a few lists who rely on that.

    I've tried by making a new class wich sets the list-style explicitly, but that seems to be overruled by the previous declarition of the main-content-div-list-style. And that's the part I don't know how to fix properly.

  • #8
    Senior Coder
    Join Date
    Jul 2009
    Location
    South Yorkshire, England
    Posts
    2,318
    Thanks
    6
    Thanked 304 Times in 303 Posts
    You are so not listening to the advice you've been given. Get your source code valid before you do anything else. Until that is as it should be, anything you are liable to do may be hacks which may break if the source ever becomes valid or even just between different browsers. The likes of abduraooft dont give out random, irrelevant advice just to get their jollies. Sort the problems in logical and methodical steps.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •