Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New Coder
    Join Date
    Jul 2008
    Posts
    71
    Thanks
    7
    Thanked 3 Times in 3 Posts

    Double url issue - htaccess? [wordpress]

    I have wordpress installed on my site.

    And i noticed that it is giving me double urls.

    This is one of my site pages:
    http://www.website.com/basic-gameplay/

    I noticed that when i re-hover over the second link from the left it will stack the URLs like this in the bottom left of the browser display(firefox&chrome):
    http://www.website.com/basic-gameplay/basic-gameplay/

    The html for the navigation looks like this:
    Code:
    <ul id="main-navi" class="navi">
    				<li><a class="test" href="pollsarchive/"></a></li>
    				<li><a class="test" href="basic-gameplay/"></a></li>
    				<li><a class="test" href="#"></a></li>
    				<li><a class="test" href="#"></a></li>
    				<li><a class="test" href="#"></a></li>
    				<li><a class="test" href="#"></a></li>
    			</ul>
    I dont see anything wrong..

    It works fine and directs traffic to the correct page, but its unsettling seeing that happen in the browser.

    Any ideas?

    my htaccess file looks like this:
    Code:
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName website.com
    
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Last edited by ch4sethe5un; 08-13-2010 at 07:08 AM.

  • #2
    New Coder
    Join Date
    Jul 2008
    Posts
    71
    Thanks
    7
    Thanked 3 Times in 3 Posts
    i also just noticed that wordpress is installed in the public_html folder is that not considered the root?

  • #3
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,801
    Thanks
    160
    Thanked 2,216 Times in 2,203 Posts
    Blog Entries
    1
    <ul id="main-navi" class="navi">
    <li><a class="test" href="pollsarchive/"></a></li>
    <li><a class="test" href="basic-gameplay/"></a></li>
    <li><a class="test" href="#"></a></li>
    <li><a class="test" href="#"></a></li>
    <li><a class="test" href="#"></a></li>
    <li><a class="test" href="#"></a></li>
    </ul>
    Use absolute paths, like
    Code:
    <ul id="main-navi" class="navi">
    				<li><a class="test" href="/pollsarchive/"></a></li>
    				<li><a class="test" href="/basic-gameplay/"></a></li>
    				
    			</ul>
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • Users who have thanked abduraooft for this post:

    ch4sethe5un (08-13-2010)

  • #4
    New Coder
    Join Date
    Jul 2008
    Posts
    71
    Thanks
    7
    Thanked 3 Times in 3 Posts
    that was a very quick fix. What is the difference between what i had and absolute paths?

    I mean besides the fact that it was not working correctly, why is it valid mark-up?


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •