Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Regular Coder
    Join Date
    Apr 2010
    Posts
    207
    Thanks
    30
    Thanked 0 Times in 0 Posts

    How to use transparency for all browsers

    OK, so I use

    color: transparent;

    on a:, and a:hover, which works well on Firefox, but not on IE8. In IE8, I get a white color surrounding the link. How can I make this transparent in IE8, and Firefox????? Thanks.

    P.S. I read an article that talked about using visibility: hidden; , but that made the entire image with the link disappear, as you might expect.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Just curious why would you want transparent links? No one would be able to see them. What links are you referring to that have the color on them? There is probably a better solution.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    Regular Coder
    Join Date
    Apr 2010
    Posts
    207
    Thanks
    30
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by _Aerospace_Eng_ View Post
    Just curious why would you want transparent links? No one would be able to see them. What links are you referring to that have the color on them? There is probably a better solution.
    I dont want the links to be transparent. here is the deal:

    On my page, there is a logo at the top of the page. It takes you to the home page when you click it. Unfortunately, when you click it, you see an ugly box around it. I made the a, and a:hover color property transparent, and ta-da...no ugly box...in Firefox, at least. The box is still there in IE8. Now I need to make that box disappear....WITHOUT making the actual image disappear.

    thanks

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Okay, don't make your links transparent, and add outline:0; to that link. Problem solved. If you weren't so vague on what you were trying to do in the first place this is the solution I would have given you all along.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • Users who have thanked _Aerospace_Eng_ for this post:

    CarlMartin10 (07-06-2010)

  • #5
    Regular Coder
    Join Date
    Apr 2010
    Posts
    207
    Thanks
    30
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by _Aerospace_Eng_ View Post
    Okay, don't make your links transparent, and add outline:0; to that link. Problem solved. If you weren't so vague on what you were trying to do in the first place this is the solution I would have given you all along.
    That worked. Thanks. I try not to be too vague, but sometimes it happens. i will be more descriptive in the future.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •