Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Jan 2010
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    POST returned empty in IE

    I have two forms on a page, one is being used for login, and the other for searching. In FF the second form works fine, and retrieves the POST data from taht page that sent it. However in IE, no POST data is sent whatsoever for the second form, and im flumoxxed as to why. The forms have different names and are set up as i think they should be, any ideas??

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,855
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    The forms have different names and are set up as i think they should be, any ideas??
    Insufficient data provided. Can we have your code a link to your page?
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #3
    New Coder
    Join Date
    Jan 2010
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    After quite a bit of searching i managed to find a note at http://www.webdeveloper.com/forum/sh...d.php?t=172601 that mentioned..

    "There is an IE bug that prevents form submittion if there is only one textfield and one submit button. To get around it place a second textfield and make it invisible using CSS."

    I tried this an it worked a treat, who would have guessed it!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •