Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    May 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IE hover not working properly

    Hey guys. I can't figure this out for the life of me. FF and Chrome both work fine but IE 7 and 8 don't work the same way. The images on the right side of the featured section of the website not only look like they are loading where the entry text is under the image but when you mouse over the entry text below the image the image above it gets bigger. The website I am referring to is www.droidedup.com. Any help would definitely be appreciated as I am at a total loss.

  • #2
    Regular Coder
    Join Date
    Apr 2008
    Posts
    685
    Thanks
    15
    Thanked 105 Times in 104 Posts
    What's meant to happen on hover, anything at all? Maybe one of your plugins could be interferring, although the CSS is a bit all over the shop, and on another note the site sometimes becomes randomly unresponsive on my Firefox!

  • #3
    New to the CF scene
    Join Date
    May 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    As of right now nothing is suppose to happen on hover. In regards to being all over the shop, I hired someone in China (supposedly a programmer) to redo the featured section of the site. The re-did it and then left me hanging after I noticed this IE problem. I normally don't use IE and I didn't even think to test it before I paid them. Now I'm stuck.

  • #4
    Regular Coder
    Join Date
    Apr 2008
    Posts
    685
    Thanks
    15
    Thanked 105 Times in 104 Posts
    Ah well having a look it seems as if this is the main problem:

    Code:
    a img, a:hover img {
    
    
    
    position:relative;
    
    
    
    text-decoration:none;
    
    
    
    z-index:2;
    
    
    
    cursor: pointer;
    
    
    
    }
    Now I don't know what uses this has in general so i'd just override it for your featured section, by adding this to the bottom of your stylesheet:

    Code:
    #featured a img, #featured a:hover img{ position:static; }
    This should stop the images getting bigger on hover..

    Then for the loading symbol I suspect it is something to do with this found in style1.css:

    Code:
    .featured{
    /*border-left:1px solid #aaa;*/
    background: #fff url(../images/skin1/preload.gif) no-repeat center center;
    }
    It's adding the loading sign as the background to anything given with class featured, and each of the featured sections has this class, so i'd just removed this altogether from the stylesheet/comment it out because I can't see any particular use for it?

    Anyway that should fix the two IE problems you noticed!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •