Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,182
    Thanks
    174
    Thanked 257 Times in 257 Posts

    css drop down menu issues

    I have a css drop down menu that i have used before because it never fails me. Although this time it seems to be messing up in IE7. It works fine in every other browser.

    http://media.ebby.com/65/

    If you click on the link you can see what i mean when you hover over the top menu. It matches well in FF but not in IE7. Am i missing something, or does it have to do with my Javascript?

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,852
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    An easy way would be as follows
    Code:
    #main_nav li{
    position:relative;
    }
    #main_nav li:hover ul, #main_nav li.sfhover ul {
    	left: 0;
    	top:65px;
    	float:none;
    }
    PS: Your sfhover script needs to be corrected as
    Code:
    var sfEls = document.getElementById("main_nav").getElementsByTagName("LI");
    Last edited by abduraooft; 05-21-2010 at 04:15 PM.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • Users who have thanked abduraooft for this post:

    jcdevelopment (05-21-2010)

  • #3
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,182
    Thanks
    174
    Thanked 257 Times in 257 Posts
    So, now why on earth are the links in the drop down wrapping almost after every word? I tried adjusting everything from the links to the "li". The arrows also do not show. You can see the difference between FF and IE7.

    What am i doing wring there?

  • #4
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,182
    Thanks
    174
    Thanked 257 Times in 257 Posts
    I was able to fix the problem with the links wrapping after every word by setting a width. Now the only problem i have is that the "list-style-image" is not showing up.

    It shows up on all of the rest of the browsers but IE7. Surprise, surprise.

    If anyone can help i would appreciate it. Thanks!

  • #5
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    There are many errors.

    HTML report.



    Frank
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •