Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Jan 2010
    Location
    England
    Posts
    35
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Question 1st Post Ever :) Chrome & safari CSS background issue

    hello people

    This is my 1st post on the site, ive been studying at university the last 2 years now and im havin a problem with one of my projects im hoping you can help...

    Ive built a prototype interface using css and xhtml and im at the browser compatibilty testing stage. The problem im having is that im using a background image in CSS to fill the full screen then ive got div content over the top and in IE and opera the display is correct (although opera does have a slight change its not that noticable) but in chrome and safari (and possibly firefox which im yet still to test) the background image is repeating horiz and vert when the window is in full screen size ( im using a 17in laptop in 1920x1200 display)

    the image is a lanscape so the repeat looks bad im wanting the 1 image to fill the fullscreen in all browsers even on the high end resolutions, if im using that res imsure other ppl are too.

    i have tryed the no-repeat function but all that does is literally not repeat it lol and leaves a white gap at botom and right side

    il paste in some of the code that i think may be of help to with this issue ive commented out some of my efforts to try fix it


    @charset "utf-8";
    /* CSS Document */

    body {
    /*background-color: white;*/
    background-image:url('images/seaback.jpg');
    background-repeat: no-repeat;
    /*background-attachment: fixed;*/
    /*background-position: center;*/
    font-family: Arial, Helvetica, sans-serif;
    font-size: 12px;
    line-height: 24px;
    color: black;
    }


    i dont know if ive missed any info hope i can resolve this issue

    cheers peeps

  • #2
    New Coder
    Join Date
    Jan 2010
    Location
    England
    Posts
    35
    Thanks
    4
    Thanked 0 Times in 0 Posts
    hey guys please disregard this post lol ive since resolved the issue i cant believ i didnt realise what it was

    i have 4 images that i was testing for a background and the one id ended up choosing was different in pixel size to the rest so it didnt fill screen lol

    the images that were exactly 1920x1200 worked like a treat in allbrowsers

    silly me


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •