Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    horizontal dropdown nav - IE6 CSS issues

    Hi--

    I'm building a horizontal nav that needs to work in (ugh) IE6. Of course it works fine in every browser but IE6. I was hoping someone could give me some help.

    Here is a link to a test version of the nav:
    http://www.qea.us/test/example/dropdown.html


    I used ugly colors for testing purposes. Basically (and you'll have to see this for yourself in IE6 I suppose) the display:block code is not working properly.

    When you mouse over the top level tabs, the background should stay red. In IE6 if your cursor touches the text (which I've outlined in white for ease of viewing), the red turns off. It works fine if the cursor doesn't touch the text.

    The nav is built using an unordered list with CSS.

    I can't for the life of me figure out what's up. I've tried all sorts of IE6 hacks.

    If you're industrious here is a zip file with all the source files (CSS & HTML)

    http://www.qea.us/test/example.zip

    Thanks for any tips!

  • #2
    New Coder
    Join Date
    Mar 2009
    Location
    Milton Keynes, England
    Posts
    54
    Thanks
    4
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by 44r0ng View Post
    Hi--
    Here is a link to a test version of the nav:
    http://www.qea.us/test/example/dropdown.html

    I used ugly colors for testing purposes. Basically (and you'll have to see this for yourself in IE6 I suppose) the display:block code is not working properly.

    When you mouse over the top level tabs, the background should stay red. In IE6 if your cursor touches the text (which I've outlined in white for ease of viewing), the red turns off. It works fine if the cursor doesn't touch the text.
    Hi,

    Maybe you have since fixed this issue, but when I mouseover your tabs, regardless if I touch the text or not the background of the sub-tabs stays red.

    Seems to be working fine to me.

  • #3
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi. Thank you for checking. I haven't touched the code since I posted the link.

    Maybe you have since fixed this issue, but when I mouseover your tabs, regardless if I touch the text or not the background of the sub-tabs stays red.
    Sorry for not being totally clear in expressing the issue I'm having. The subnav is working fine. It's the top tab that's supposed to remain red when you're hovering over it, even when you mouse over the anchor text. Currently, in IE, when you mouse over the anchor text the red in the top tab goes away.

  • #4
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I ended up scrapping this and using Superfish. Much better solution and compatible in IE6.

  • #5
    New Coder
    Join Date
    Mar 2009
    Location
    Milton Keynes, England
    Posts
    54
    Thanks
    4
    Thanked 4 Times in 4 Posts
    Aha, I guess I misunderstood , sorry I couldn't have been more help.

    Glad you have found a solution.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •