Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question My BG is 100% of the browser height, but if I have to scroll its cut off..... (CSS)

    Hello there, this is my first post on this forum.

    I can't seem to figure out whats going on here, but if you visit
    http://www.arroworks.com/northpoint
    you can see that when the page is maximized its just fine, the background flows fine, but then if you take the browser and make it smaller, so you have to scroll, the background gets 'chopped off'..

    I'm assuming its because im telilng the background to go "100%", which it is doing, but its calculating 100% of the browsers current size, which is smaller cause I made the browser that size....

    If you make your browser maximized (And/or) so you don't have to scroll, its fine, but if you resize your browser so you HAVE to scroll, its screwing up the bottom of where you have to scroll down to, and I can't figure out why.....

    ITS DRIVING ME CRAZY!
    Any help on this would be greatly appreciated
    -THX

  • #2
    Senior Coder
    Join Date
    Oct 2005
    Posts
    1,340
    Thanks
    0
    Thanked 61 Times in 60 Posts
    Quote Originally Posted by arroworks View Post
    I'm assuming its because im telilng the background to go "100%", which it is doing, but its calculating 100% of the browsers current size, which is smaller cause I made the browser that size....
    Yep. Look at it this way. That element is how many pixels? You said it's 100% but 100% of what? You should always know and be able to answer those two questions.

    I don't see the problem because I always have to scroll. Plus, you have html errors that need correcting.
    Last edited by drhowarddrfine; 11-18-2009 at 02:34 AM.

  • #3
    New to the CF scene
    Join Date
    Nov 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I fixed it, I just made a table be 100% height with css, and it works just fine....

    thx for the reply!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •