Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 14 of 14
  1. #1
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    expanding div works in IE7, FF, Safari, etc, but NOT IE8!!

    Hey all, the test page is here. Notice when you expand the "view more details" in IE8 to the point where it is supposed to push the page down, it doesn't! But it does in FF/Safari.

    HTML

    CSS

    Potentially relevant CSS:

    Code:
    body {
    	margin: 0;
    	padding: 0;
    	min-height:0;
    }
    div.container {
    	width:100px;
    	
    }
    div.outerBody {
    	width:100%;
    	min-height:0;
    }
    div.innerBody {
    	width:100%;
    	background-image:url("../../images/artist_center/body_bg.jpg");
    	background-repeat:repeat-x;
    	min-height:0px;
     	height:auto !important;
    	
    	background-color:#cedce5;
    	text-align:center;
    	margin: 0;
    	position:absolute;
    }
    
    div.tabContent {
    	width:945px;
    	min-height:596px;
    	border:solid 1px #cccccc;
    	float:left;
    	position:relative;
    	margin-left:14px;
    	padding-bottom:14px;
    	margin-bottom:14px;
    	
    }
    I'm using clearfix to make things work in IE7, but clearly there's some kind of other problem going on.

    Thanks for any help!
    Last edited by oldnoisy; 11-11-2009 at 02:10 AM.

  • #2
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,675
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Hello oldnoisy,
    Those links are both the same. HTML link gives you style.css when clicked.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #3
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Excavator View Post
    Hello oldnoisy,
    Those links are both the same. HTML link gives you style.css when clicked.
    Link edited

  • #4
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,675
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    I don't think you're allowed to put a div inside an li like that. It's invalid no matter what DocType I checked with. That might make for some unpredictable results.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #5
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Excavator View Post
    I don't think you're allowed to put a div inside an li like that. It's invalid no matter what DocType I checked with. That might make for some unpredictable results.
    The W3C XHTML 1.1 validator doesn't bring that up specifically as a problem. One other thing I noticed is that when you select the text on the page in IE8 after having broken the page using the expandable parts, the pages seems to redraw and everything looks fine. Then if you collapse those areas and select more random text, it shrinks again. This definitely seems like some kind of bug.

  • #6
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,675
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Quote Originally Posted by oldnoisy View Post
    The W3C XHTML 1.1 validator doesn't bring that up specifically as a problem.
    It is the very first one.
    Line 90, Column 53: document type does not allow element "div" here; assuming missing "li" start-tag
    <div class="coda_bubble">
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #7
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Excavator View Post
    It is the very first one.
    But for the entire expandable parts, there's easily 10-12 <div> inside <li>.. why that particular one?

    EDIT: I took out that entire section anyways and the problem still remains.

  • #8
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,675
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    That's just the first one. Take it out, check again and the validator just targets the next one.
    Between that, the resulting incomplete ul and li 's and the id's being re-used (#stats-northeast and #main)... it's a wonder it works at all.

    I would recomend going through the list of errors, starting at the top, and fix every one that your able.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #9
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Okay it's 100% validated.. still not working .. link is now http://www.muchomungo.com/CrowdTwist...g_regions.html

  • #10
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,675
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    I don't understand. FF3.5 and IE8 both seem to work perfectly now. I think.
    Was your problem in IE6?
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #11
    Senior Coder Arbitrator's Avatar
    Join Date
    Mar 2006
    Location
    Splendora, Texas, United States of America
    Posts
    3,302
    Thanks
    28
    Thanked 276 Times in 270 Posts
    Quote Originally Posted by oldnoisy View Post
    Okay it's 100% validated.. still not working .. link is now http://www.muchomungo.com/CrowdTwist...g_regions.html
    Both "View More Results" links are working fine for me in WIE8 on Vista on both normal view and Compatibility View.
    For every complex problem, there is an answer that is clear, simple, and wrong.

  • #12
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    They work fine yes, but do you see at the bottom how it breaks the page when it expands?

  • #13
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    It does work for me in compatibility mode as well though.

  • #14
    New Coder
    Join Date
    Sep 2009
    Location
    Montreal, QC
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I'd love a good solution, but for the time being I've just added

    <meta http-equiv="X-UA-Compatible" content="IE=7" />

    in the <head> which forces IE8 to act like IE7. Anyone see a problem with this?


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •