Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Oct 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Run an executable with arguments from an HTML mail message

    Hopefully I posted this in the right forum. I want one of my applications to send an HTML email message to a user with a hyper link in it to start up an executable with arguments passed to it. It works fine if I just specify the executable path with no arguments. But if I pass the arguments then Outlook says it can't find the file.

    Here is the line that I add to the email message body to start the exe only:

    Code:
    "<a href="""C:\program files\someFolder\myApp.exe""">Click here</a> to run program."
    but if I add the arguments it doesn't work:

    Code:
    "<a href="""C:\program files\someFolder\myApp.exe cust=1234 order=5678""">Click here</a> to run program."
    Has anyone done this before or know what I need to do to make it work with arguments? Thanks...

  • #2
    Senior Coder rnd me's Avatar
    Join Date
    Jun 2007
    Location
    Urbana
    Posts
    4,189
    Thanks
    10
    Thanked 569 Times in 550 Posts
    arguments are not part of a path, so they can't just be 'tacked on'.

    however , you can simply create a batch file that does whatever you want, and link to it.
    my site (updated 13/9/26)
    BROWSER STATS [% share] (2014/1/19) IE7:0.2, IE8:6.7, IE11:7.4, IE9:3.8, IE10:4.4, FF:18.3, CH:43.6, SF:7.8, MOBILE:27.5


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •