Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    NSG
    NSG is offline
    New Coder
    Join Date
    Aug 2009
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thumbs down Bold/Unbold (bold when new content, unbold when not new)

    On my website, I recently began doing mod rewrites and the links no longer correctly go bold and unbold. I am unsure why, and if anyone could offer some advice it'd be greatly appreciated:

    http://boards.nsgstation.com/the-asylum-b135

    If you click a thread, it unbolds it, but if a new post is made the thread never goes back to being bold. Please help, thank you!

  • #2
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    On my PC the unbolding is caused by the browsing history. If you clear the browsing history, the link will revert. I don't know what you can do about it unless you can set the browser not to save in browsing history, but that would only work on your PC, not necessarily on the remote one.
    Frank

    Also you have a lot of code before the Doctype. The Doctype should be the FIRST line of your code. The <style> </style>code should be in the <head></head> part of the page.
    Last edited by effpeetee; 08-28-2009 at 11:27 AM.
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.

  • #3
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,801
    Thanks
    160
    Thanked 2,216 Times in 2,203 Posts
    Blog Entries
    1
    The CSS contains
    Code:
    a.SubjectLink {/*ign.php (line 151)*/
    ......
    font-weight:bold;
    ....
    }
    a.SubjectLink:visited {/*ign.php (line 169)*/
    ......
    font-weight:normal;
    ....
    }
    Refer http://www.w3schools.com/CSS/css_pseudo_classes.asp
    Last edited by abduraooft; 08-29-2009 at 05:29 AM.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #4
    NSG
    NSG is offline
    New Coder
    Join Date
    Aug 2009
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I still do not know of a fix. Same behavior is still happening. Help? It didn't start happening until I began doing the mod_rewrites.

    Also put doctype at the top, thanks for the tip.

  • #5
    NSG
    NSG is offline
    New Coder
    Join Date
    Aug 2009
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I use stylesheets so the psuedo url would be too much I think as I'd have to edit multiple stylesheets. I've been trying to fix it all day, but nothing is working.

  • #6
    Master Coder
    Join Date
    Apr 2003
    Location
    in my house
    Posts
    5,211
    Thanks
    39
    Thanked 201 Times in 197 Posts
    Your doctype should not be surrounded by comment tags because the browsers can't read it. remove the <!-- and the -->.

    I tried to run your page through the validator and it wouldn't work saying you had errors preventing it.

    Tip: put all your css into an external file so you will only have one to chnage instead of many.

    bazz
    "The day you stop learning is the day you become obsolete"! - my late Dad.

    Why do some people say "I don't know for sure"? If they don't know for sure then, they don't know!
    Useful MySQL resource
    Useful MySQL link


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •