Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Regular Coder
    Join Date
    Nov 2007
    Location
    Chicago
    Posts
    134
    Thanks
    2
    Thanked 9 Times in 9 Posts

    Question Problem with unordered list in IE

    For the life of me, I can't figure out what is causing this problem.

    One of my sites (www.whyilovechicago.com) has a blog that I host on Blogger. I customized the blog layout to look exactly like the rest of the site, going as far as to call all of the CSS and images from my hosted domain.

    I have an unordered list displayed inline across the top of the content. In Firefox, both the blog and the website look fine. However in IE, the website looks fine BUT the blog displays the navigation links on separate lines.

    If the CSS is the same (I'm calling the same file), WTF is going on here? I'd appreciate if someone could take a look and see if I'm missing something...

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,801
    Thanks
    160
    Thanked 2,216 Times in 2,203 Posts
    Blog Entries
    1
    For me, those list items are in seperate lines even in FF.
    Anyway have a try by setting float:left; to your #content-nav ul li

    PS: Know why using tables for layout is stupid! and have a look a good 2 column layout using CSS at http://bonrouge.com/2c-hf-fluid(r).php
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • Users who have thanked abduraooft for this post:

    arthurakay (05-20-2009)

  • #3
    Regular Coder
    Join Date
    Nov 2007
    Location
    Chicago
    Posts
    134
    Thanks
    2
    Thanked 9 Times in 9 Posts
    Aha, that has fixed it for me in IE6 and 7. Thanks for that! If you don't mind, let me know if it works for you in Firefox now - it's odd that it didn't work for you before.

  • #4
    Senior Coder
    Join Date
    Oct 2005
    Posts
    1,340
    Thanks
    0
    Thanked 61 Times in 60 Posts
    Quote Originally Posted by arthurakay View Post
    However in IE, the website looks fine BUT the blog displays the navigation links on separate lines.

    If the CSS is the same (I'm calling the same file), WTF is going on here?
    See my first link below about IE8 alone. IE7 is much worse. Never, ever trust IE to do anything right.

  • #5
    Regular Coder
    Join Date
    Nov 2007
    Location
    Chicago
    Posts
    134
    Thanks
    2
    Thanked 9 Times in 9 Posts
    You have a very thorough look at IE8 there... good to know. Thanks!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •