Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    May 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Newbie problem with IE/FF

    Hi all,

    First post on the forum so a big hello to all!

    I am a complete plank when it comes to coding so please be gentle. I did some HTML years ago but have lost touch over time so I've chosen to use an old copy of DW8 for my small project.

    So, I have produced a frameset using DW8 and it works fine in IE, however the one frame just doesn't render properly in Firefox. There are 3 frames, TOP, MIDDLE and BOTTOM (all on top of oneanother) and the BOTTOM and MIDDLE frames are coded in exactly the same way as the TOP (except their position properties are "background-position: center top; - as opposed to bottom in this example") but they render just fine...?

    I've messed with the Frameset settings and got no joy so I tried simply openning the "TOP" frame concerned and even viewed alone still won't render properly, so I've turned my attention to the code within the frame.

    Here's the code...

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
    
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>Untitled Document</title>
    <style type="text/css">
    <!--
    body {
    	background-image: url(Images/top.jpg);
    	background-repeat: no-repeat;
    	background-position: center bottom;
    }
    -->
    </style>
    </head>
    
    <body>
    </body>
    </html>
    I've checked the DTD issue, and I'm fairly sure that I am using the wrong DTD for Frames looking at previous posts and sticky's, however I've tried to change that and it has no effect.

    It's a background image that in IE sits in exactly the right place, however in Firefox it appears off the top of the screen with about 20 pixels of the bgimage peeking out at the top of the screen.

    Any help would be MUCH appreciated. Tried a few ways to bypass this issue, but to no avail.

    Many thanks,

    Chris.

    By the way, I ran this through the W3C validator and it came out fine! Odd huh?
    Last edited by chris-zenergy; 05-15-2009 at 02:38 PM.

  • #2
    New to the CF scene
    Join Date
    May 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Sorted it!!! Moderators please close thread.

    Hi guys,

    Just to let you know, I sorted it myself in the end (after 2 and a half hours hunting around!), see below for missing code in red that DW doesn't insert...

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>Untitled Document</title>
    <style type="text/css">
    <!--
    body {
    	background-image: url(Images/top.jpg);
    	background-repeat: no-repeat;
    	background-position: center bottom;
    	background-attachment: fixed; 
    	height:100%; 
    }
    -->
    </style>
    </head>
    
    <body>
    </body>
    </html>
    Moderators please close thread ;D


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •