Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder kyllle's Avatar
    Join Date
    Mar 2008
    Posts
    334
    Thanks
    85
    Thanked 2 Times in 2 Posts

    Stylesheet Problems & IE Nav problems

    Hi all,

    I have a few problems concerning the following web page:

    http://www.glen-lodge.co.uk/testing/ws/medBasic.html


    Firstly I have been styling this page using an external stylesheet up until I added the JavaScript accordion, when I added the styles of the accordion to the external style sheet the accordion just wouldn't work so Iv had to add it to the head section of the page and any other styles that Iv wanted to add to the page since have also had to be added to the head section or they will just not show up on the page, is there somewhere Im going wrong with this?

    Also, I have added a drop down nav which seems to work fine in firefox but in ie the drop down part of the nav just doesnt seem to display and I am really unsure how to make this work.

    I would really love as much advice and help as possible with this so I can learn how to fix these problems and use the techniques in the future.

    Many thanks in advance!

    Kyle

  • #2
    Regular Coder kyllle's Avatar
    Join Date
    Mar 2008
    Posts
    334
    Thanks
    85
    Thanked 2 Times in 2 Posts
    Hey all,

    can anyone help me with my problem? I just need pointed in the right direction and the hopefully all will be grand!

    Thanks!

    Kyle

  • #3
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,950
    Thanks
    9
    Thanked 724 Times in 718 Posts
    Hi Kylle

    Just been messing with your nav non-drop issue.

    Cannot say I understand this, it might be just another IE "feature", but try removing position:relative from .wrapper - I don't think this is used elsewhere and it seems to solve the dropdown issue.

    Haven't looked at the stylesheet issue - but you I noticed one error in your css:

    Code:
    #right .effectCurve{
    	width: 190px;
    	background: url(images/effectRep.gif) repeat-y;
    	margin: 0 auto;
    	{

  • Users who have thanked SB65 for this post:

    kyllle (05-14-2009)

  • #4
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,950
    Thanks
    9
    Thanked 724 Times in 718 Posts
    And also:

    Code:
    *html .infoLeft {...}    (line 220)
    *html .paypal {...}    (line 234)
    are both wrong - there should be a space between * and html.

    The css validator is good for finding this sort of thing.

  • Users who have thanked SB65 for this post:

    kyllle (05-14-2009)

  • #5
    Regular Coder kyllle's Avatar
    Join Date
    Mar 2008
    Posts
    334
    Thanks
    85
    Thanked 2 Times in 2 Posts
    Hi SB65,

    Thanks so much for taking the time to offer advice, Iv takin out posistion: relative from .wrapper but Im afraid it still isnt wroking for me?

    Thanks again

    Kyle

  • #6
    Regular Coder kyllle's Avatar
    Join Date
    Mar 2008
    Posts
    334
    Thanks
    85
    Thanked 2 Times in 2 Posts
    ahhhhhh I got it working, thanks SB65, i was dropping the new stylesheet into the wrong directory there!!! have to try and add the styles into the external stylesheet now :s

    thanks again!!

    Kyle


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •