Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 7 of 7
  1. #1
    New to the CF scene
    Join Date
    May 2009
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    A problem with disappearing div-boxes in IE 7

    I have a problem with the content div boxes I use on my page to display news. In firefox, opera and chrome everything looks fine, but in IE 7 the boxes stack on top of each other and the background disappears. The weird thing is that it only happens on the front page; if you click on the read-more link the problem disappears. I can't find any related differences between the two pages. Can anyone see what the problem is with my front page?

    You can find the page here:
    http://ozrealm.com/bsk/wordpress/

    How the page is supposed to be:
    http://bildr.no/view/408667
    And how it is in IE 7:
    http://bildr.no/view/408669

    I'm really stuck here. Help would be appreciated.
    Last edited by chickenslowfood; 05-13-2009 at 04:38 PM.

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,854
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    You have some errors in your markup, see http://validator.w3.org/check?uri=ht...Inline&group=0
    Fix them first.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #3
    New to the CF scene
    Join Date
    May 2009
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Now the page validates xhtml 1.0 strict without warnings

    It was just some form stuff to clean up, nothing to do with the IE bug. Thanks anyway for the tip.

  • #4
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,854
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    It has something to do with your unitpngfix.js. Removing that script makes it OK in IE7

    Edit: Have a try by editing that script file and comment/remove the line es.height=el.clientHeight+'px';
    Last edited by abduraooft; 05-13-2009 at 04:32 PM.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #5
    New to the CF scene
    Join Date
    May 2009
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    You solved it!

    I had actually linked to the script twice, one of them outside the lt IE 7 tag. Removing the last one fixed the problem, although I don't understand.

    What did you mean by "by removing the script the page is OK"?

    Thanks for the help

  • #6
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,854
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    What did you mean by "by removing the script the page is OK"?
    I observed the following snippet in your code
    Code:
    <script type="text/javascript" src="Friidrett_files/unitpngfix.js"></script>
    , and when I just removed it, IE7 displayed it well.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #7
    New to the CF scene
    Join Date
    May 2009
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    yes, I understood that from the first post. I just thought the "OK" meant that somethink else was wrong/possible to improve.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •