Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New Coder
    Join Date
    Mar 2009
    Posts
    38
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Submenu disappears on mouseover in IE 6

    For some reason in IE 6, my submenu doesn't seem to stick around when I try to get to links on it.

    www.laduefootball.org

  • #2
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,951
    Thanks
    9
    Thanked 724 Times in 718 Posts
    I get the issue in IE7 as well.

    It looks as if the hover is lost as the mouse moves off the top level menu div. Try adding a background colour to your second level menu ul:

    Code:
    .menu .sub {
    display:table; 
    margin:0 auto; 
    padding:0; 
    list-style:none;
    background-color:#003366;
    }
    This looks like it works in IE6 and IE7 using the IE developer toolbar.

  • Users who have thanked SB65 for this post:

    teamleaf (05-16-2009)

  • #3
    New to the CF scene
    Join Date
    May 2009
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I think javascript can fix that.

  • #4
    New Coder
    Join Date
    Mar 2009
    Posts
    38
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thanks SB! I'm not understanding why it needs a background to maintain the hover ability but whatever. I'm happy.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •