Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Feb 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Layout Problem (Absolute beginner!)

    Hello there,
    For starters I have to say that I am an absolute beginner to web design so any excellent help you might be able to give might have to be spelt out for me. Also I did not build this site, I just need to make some changes to the layout and presentation then stick it back up.

    Okay so the original site is here...

    http://extra.shu.ac.uk/cetl/

    What I needed to do was pull out the huge header image below the top banner (I have some graphic design experience) and replace it with something simpler and smaller which I did. The end result of this though is that because the left navigation menu has shifted up the page I now have a dead area that sits just below the header which does not allow me to access any links. Whatever I try to change this code that manages this area it either has no effect OR completely messes up the formatting of the entire page, especially the footer.

    I haven't updated the live site with the changes but here are links to the css and html files which I hope are enough for you guys to look at.

    http://www.mediafire.com/file/eymozy...bsitetest.html

    http://www.mediafire.com/file/mmjmzqj5eme/style.css

    I know there are many other problems with the website but if I can just get over this one obstacle I can get my head down and actually learn how to fix the other bugs! cheers for your help in advance

  • #2
    Regular Coder
    Join Date
    Jul 2008
    Location
    UK
    Posts
    116
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Ive looked at the site and cant see the problems you describe eveyrhting looks fine in IE7 and FF3

  • #3
    Regular Coder
    Join Date
    Nov 2008
    Posts
    317
    Thanks
    159
    Thanked 0 Times in 0 Posts
    I don't see the problem either...
    Last edited by cincinnatiboy4867; 02-18-2009 at 02:44 PM.

  • #4
    New to the CF scene
    Join Date
    Feb 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Nope its not on the live site! It works fine at the moment but if you look at the html/css link below I have removed the large image which causes the problem.

  • #5
    Regular Coder
    Join Date
    Jan 2009
    Posts
    316
    Thanks
    7
    Thanked 92 Times in 91 Posts
    Change these two pieces in your CSS:
    Code:
    #header{
    			position:absolute;
    			top:0;
    			width:960px;
    			height:220px;
    			margin:0px 0px 0px 0px;
    			padding:0px 10px 0px 10px;
    			display:block;
    			overflow:hidden;
    			}
    Code:
    #page-navigation {
    			margin:0px 0px 0px 0px;
    			padding:0px 0px 0px 0px;
    			position:relative;
    			z-index:11;
    			}
    Your header is still set at the old size of 374px. Also, your #header-layout has a z-index of 10, so by giving the navigation a z-index of 11, it will work.

  • Users who have thanked Fisher for this post:

    baileyhsi (02-18-2009)

  • #6
    New to the CF scene
    Join Date
    Feb 2009
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Bosh! Brilliant! Thankyou so much! Much appreciated!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •