Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New to the CF scene
    Join Date
    Oct 2008
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    horizontal menu displays vertically in IE

    I built this site for my mechanic a while ago, and about a week ago IE started displaying the menu vertically instead of horizontally?

    I haven't touched anything on the site for ages so have no idea why this would have changed all of a sudden.

    If someone can please take a look I'd really appreciate it...

    www.atozimports.com.au

    Works fine in Firefox, chrome, netscape and "sort of ok" in Opera.

    If you need more info just let me know.

    Thanks

  • #2
    Senior Coder rangana's Avatar
    Join Date
    Feb 2008
    Location
    Cebu City, Philippines
    Posts
    1,752
    Thanks
    65
    Thanked 372 Times in 365 Posts
    Hi Mike,

    First of all, Welcome on board.

    Your problem is highlighted:
    Code:
    <script type="text/javascript">
    var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
    document.write(unescape("&#37;3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
    </script>
    <script type="text/javascript">
    var pageTracker = _gat._getTracker("UA-5736719-1");
    pageTracker._trackPageview();
    </script>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    Anything, above the doctype, pushes ie into Quirksmode.

    Place it anywhere on the page, except above the doctype, but I suggest to place it before the closing of the body tag (</body>), as what GA, instructed.

    Hope that helps.
    Learn how to javascript at 02geek

    The more you learn, the more you'll realize there's much more to learn
    Ray.ph

  • Users who have thanked rangana for this post:

    mikexavier (10-16-2008)

  • #3
    New to the CF scene
    Join Date
    Oct 2008
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks for taking a look Rangana.

    I moved

    <script type="text/javascript">
    var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
    document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
    </script>
    <script type="text/javascript">
    var pageTracker = _gat._getTracker("UA-5736719-1");
    pageTracker._trackPageview();
    </script>

    to just before the closing of the body tag, uploaded the index file, refreshed IE but it's still displaying the same.

    Any other ideas?

  • #4
    New to the CF scene
    Join Date
    Oct 2008
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hey Rangana, checked through the rest of the site for:

    <script type="text/javascript">
    var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
    document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
    </script>
    <script type="text/javascript">
    var pageTracker = _gat._getTracker("UA-5736719-1");
    pageTracker._trackPageview();
    </script>

    I had it on another page for some reason? After deleting it, we're back to normal

    Thanks for pointing it out, can't believe how fast you responded!


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •