Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New to the CF scene
    Join Date
    Jul 2008
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Firefox won't show flash object

    Hey folks,
    I'm stuck at work trying to get a flash object to display in Firefox. It's displayed just fine in IE so we're guessing that something went wrong in the embed tag. Here's the code in question:

    <OBJECT classid='clsid27CDB6E-AE6D-11cf-96B8-444553540000' codebase='http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0' width='200' height='180' id='charts' >
    <PARAM NAME='movie' VALUE='framework/charts/charts.swf?library_path=framework%2Fcharts%2Fcharts_library&amp;stage_width=200&amp;stage_height=180 &amp;php_source=institution_residence_chart_data.php%3Fid%3D12336%26chart_type%3D%27ethnic%27&amp;li cense=H1EYFUDK2M-NLATYPWU28RU1PSTILK' />
    <PARAM NAME='quality' VALUE='high' /><param name='allowScriptAccess' value='sameDomain' /><PARAM NAME='bgcolor' VALUE='#666666' />
    <EMBED src='framework/charts/charts.swf?library_path=framework%2Fcharts%2Fcharts_library&amp;stage_width=200&amp;stage_height=180 &amp;php_source=institution_residence_chart_data.php%3Fid%3D12336%26chart_type%3D%27ethnic%27&amp;li cense=H1EYFUDK2M-NLATYPWU28RU1PSTILK' quality='high' bgcolor='#666666' width='200' height='180' NAME='charts' allowScriptAccess='sameDomain' swLiveConnect='true' TYPE='application/x-shockwave-flash' PLUGINSPAGE='http://www.macromedia.com/go/getflashplayer'></EMBED>
    </OBJECT>
    Anybody see anything that would prevent Firefox from displaying the object? Thanks a bunch in advance!

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Code:
    <OBJECT classid='clsid:D27CDB6E-AE6D-11cf-96B8-444553540000' codebase='http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0' width='200' height='180' id='charts' >
    <PARAM NAME='movie' VALUE='framework/charts/charts.swf?library_path=framework%2Fcharts%2Fcharts_library&amp;stage_width=200&amp;stage_height=180 &amp;php_source=institution_residence_chart_data.php%3Fid%3D12336%26chart_type%3D%27ethnic%27&amp;li cense=H1EYFUDK2M-NLATYPWU28RU1PSTILK' />
    <PARAM NAME='quality' VALUE='high' /><param name='allowScriptAccess' value='sameDomain' /><PARAM NAME='bgcolor' VALUE='#666666' />
    <EMBED src='framework/charts/charts.swf?library_path=framework%2Fcharts%2Fcharts_library&amp;stage_width=200&amp;stage_height=180 &amp;php_source=institution_residence_chart_data.php%3Fid%3D12336%26chart_type%3D%27ethnic%27&amp;li cense=H1EYFUDK2M-NLATYPWU28RU1PSTILK' quality='high' bgcolor='#666666' width='200' height='180' NAME='charts' allowScriptAccess='sameDomain' swLiveConnect='true' TYPE='application/x-shockwave-flash' PLUGINSPAGE='http://www.macromedia.com/go/getflashplayer'></EMBED>
    </OBJECT>
    I suggest you look into SWFObject
    http://code.google.com/p/swfobject/
    You also have some spaces in your src that should be there.
    ||||If you are getting paid to do a job, don't ask for help on it!||||


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •