Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 9 of 9
  1. #1
    New Coder
    Join Date
    Aug 2006
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    2 Link style problem

    Hi all, hoping you can help me out here... I am using dreamweaver and have set up two link styles.

    style for the majority of links and another for random links here and there.

    When i apply the second style, it changes as expected in dreamwever however when viewed in a web browser it reverts back to the first link style. I have tried a few things but nothing seems to work!

    Below is my css code - basic is used for general text on the page.
    a: is foe the majority of links, and .inverse is for random links here and there.

    my website is www.boyakasha.co.uk and as an example you will see at the top right of the page i have put the 'subscribe to RSS as .inverse but it reverts back to a:link

    any help most appreciated!

    Code:
    /************Basics******************/
    .basic { color: #F9F7ED}
    .basic {font-family: Verdana, Arial, Helvetica, sans-serif}
    .basic {  font-size:12px}
    
    /************Links******************/
    
    a:link {color: #E2B62E; text-decoration:none}
    a:visited {color: #E2B62E; text-decoration:none}
    a:hover {color:#F9F7ED; text-decoration:none; font: bold}
    
    /************Inverse Links******************/
    
    .inverse: link {color: #F9F7ED; text-decoration:none}
    .inverse: visited {color: #F9F7ED; text-decoration:none}
    .inverse: hover {color:#E2B62E; text-decoration:none; font: bold}

  • #2
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,179
    Thanks
    174
    Thanked 257 Times in 257 Posts
    try

    Code:
    .inverse a {color: #F9F7ED; text-decoration:none}
    .inverse a:visited {color: #F9F7ED; text-decoration:none}
    .inverse a:hover {color:#E2B62E; text-decoration:none; font: bold}

  • #3
    New Coder
    Join Date
    Aug 2006
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    No change
    thanks for the suggestion though..

  • #4
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,179
    Thanks
    174
    Thanked 257 Times in 257 Posts
    upload an example of your html.

  • #5
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Its likely this
    Code:
    /************Inverse Links******************/
    
    a.inverse:link {color: #F9F7ED; text-decoration:none}
    a.inverse:visited {color: #F9F7ED; text-decoration:none}
    a.inverse:hover {color:#E2B62E; text-decoration:none; font: bold}
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #6
    New Coder
    Join Date
    Aug 2006
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    No change with a.inverse :9

    here is a bit of my html

    Code:
    <a href="http://feeds.feedburner.com/Boyakasha" target="_blank" class="inverse">Subscribe to Boyakasha News Feed. </a><a href="http://news.bbc.co.uk/2/hi/help/3223484.stm" target="_blank">Help?</a>

  • #7
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,179
    Thanks
    174
    Thanked 257 Times in 257 Posts
    im not sure whats going on. It looks as if _Aerospace_Eng_ solution should work. are you sure you are uploading the style sheet?

  • #8
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Your stylesheet doesn't reflect the changes. You still have this
    Code:
    /************Basics******************/
    .basic { color: #F9F7ED}
    .basic {font-family: Verdana, Arial, Helvetica, sans-serif}
    .basic {  font-size:12px}
    
    /************Links******************/
    
    a:link {color: #E2B62E; text-decoration:none}
    a:visited {color: #E2B62E; text-decoration:none}
    a:hover {color:#F9F7ED; text-decoration:none; font: bold}
    
    /************Inverse Links******************/
    
    .inverse: link {color: #F9F7ED; text-decoration:none}
    .inverse: visited {color: #F9F7ED; text-decoration:none}
    .inverse: hover {color:#E2B62E; text-decoration:none; font: bold}
    Also that space between the : part is the problem.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #9
    New Coder
    Join Date
    Aug 2006
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hi,

    Sorry i just tested everything locally. Looks like the space before the : was the problem!! thanks i would have never known that without your help!

    cheers


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •