Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    May 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Display foreign characters in <title>

    I am having trouble displaying chinese characters in the page title. The characters display correctly throughout the body of the entire page, however they display as garbage characters in the page title. My code looks something like this:
    .
    .
    .
    <%@ page contentType="text/html; charset=UTF-8" %>
    <title>中国</title>
    .
    .
    .
    I have also tried placing:
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <meta http-equiv="Content-Language" content="zh-cn">
    before the title tag. Does anyone have advice as to how this problem can be solved?

  • #2
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Have you tried using HTML entities?

    Otherwise, you're probably just out of luck; perhaps Trebuchet MS doesn't have those characters in its plane.

  • #3
    New to the CF scene
    Join Date
    May 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have not tried html entities. However I did find out that this isnt something that is controllable with HTML. It is dependent on the settings of the individual user's operating system. To correct this error, I had to add the fonts that enable the OS to recognize the characters. These fonts can be enabled at: Start->Settings->Control Panel->Regional and Language Options->Language Tab->Supplemental Languages and Support.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •