Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Feb 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    CSS doesn't work in IE but in FF it does

    Hello,

    the site i'm talking about is www.brewed.nl/ you can really see the differents, it is acctually screwing my entire site.

    i have add the css file in every possible way but he just doesn't read it. And it isn't some spectaculair, just simple css.
    <style type="text/css">
    @import url("css.css");

    .Table_01 {
    background-color: #FFFFFF;
    background-repeat: no-repeat;
    background-position: top;

    }
    a:link {
    font-style: normal;
    color: 0c4873;
    text-decoration:inherit;
    }
    a:visited {
    color: 0c4873;
    text-decoration:inherit;
    }
    a:hover {
    color: 1a6f98;
    text-decoration:underline;
    }

    body {
    background-color: #FFF;
    margin: 0px;
    padding: 0px;
    font-size: 16px;
    font-family: Georgia;
    }h1 {
    color: 0f4159;
    }

    </style>
    <link href="css.css" rel="stylesheet" type="text/css">
    </head>

    I hope that someone can please help me with this problem!!!!

  • #2
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,179
    Thanks
    174
    Thanked 257 Times in 257 Posts
    a major thing first is that you probably need a doctype, you also have quite a few validation errors in your html markup.

    You should validate it and try and get all of the errors fixed and then see what happens, if it doesnt then i will keep looking at it.

  • #3
    New to the CF scene
    Join Date
    Feb 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    www.brewed.nl

    it is validated but it rips up the entire site when there is a big content, does anyone know how to resolves this?

    Thanks in advandes

  • #4
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,801
    Thanks
    160
    Thanked 2,216 Times in 2,203 Posts
    Blog Entries
    1
    I don't see any notable difference in my IE6 & FF, could you be more specific?
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #5
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    Try adding this to the start of your css. It makes a difference on my PC although the site is certainly not badly broken for me either.

    Frank

    Code:
    @charset "utf-8";
    /* CSS Document */
    
    *{margin:0;
    padding:0;} 
    
    .Table_01 {
    	background-color : #ffffff;
    	background-repeat : no-repeat;
    	background-position : top;
    }
    
    .Side-left {
    	background-image: url(images/site_12.gif);
    	background-repeat:repeat;
    	background-position:top;
    	position:relative;
    }
    
    .Side-right {
    	background-image: url(images/site_16.gif);
    	background-repeat:repeat;
    	background-position:top;
    	position:relative;
    }
    Last edited by effpeetee; 02-19-2008 at 11:37 AM.
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •