Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Feb 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Menu not working

    The drop down menu on this page seems to have some bugs in it.

    1. I cannot figure out how to get the menu onto the other boxes
    2. The box is transparent red, I need it to be the same as the main menu
    3. It does not diappear if the user moves the mouse to the right or left onto another box.

    Also the drop down menu is only on the "Boys" box for now but i need to get it on he girls and middle school too

    thanks

    The link is http://www.simleytrack.com/test/simleytrack.html

  • #2
    Senior Coder jcdevelopment's Avatar
    Join Date
    Oct 2007
    Location
    Cowboy Nation
    Posts
    2,179
    Thanks
    174
    Thanked 257 Times in 257 Posts
    im going to go through this one step at a time when i figure this out, and im sure others can help but the first major thing is that in FireFox, your menu is not working!!

    1. The box is transparent red, I need it to be the same as the main menu

    here is the code that its connected to and this is what i changed

    Code:
    div.sub_navigation {
    	height: 50px;
    	background-color: #000000;
    	filter:alpha(opacity=70);
    	opacity: .7;
    	-moz-opacity: .7;
    	border-top: 2px darkblue solid;
    	border-left: 2px darkblue solid;
    	border-right: 2px darkblue solid;
    	border-bottom: 0px darkblue solid;
    	vertical-align: center;
    	text-align: center;
    }
    i just added what was on the linkcontainer class, see if that works, i cant tell in FF!

    2.I cannot figure out how to get the menu onto the other boxes


    try this on the next link, add it below the boys <tr> thats id as submenu_boys, also make sure it is still wrapped in the <table> </table>

    Code:
    <tr id="submenu_girls" style="display:none" onMouseover="submenu_girls.style.display='block'" onMouseout="submenu_girls.style.display='none'">
    		<td style="filter:alpha(opacity=0)"></td>
    		<td>
    
    		  <div class="sub_navigation">		  <div align="center"><a href="http://www.classicsuburban.org/g5-bin/client.cgi?cwellOnly=1&G5statusflag=view&schoolname=&school_id=9&G5button=13&G5genie=14&vw_schoolyear=1&vw_agl=13-2-19&category_sel=&category=0 class=" target="_blank" class="main_link"main_link">Schedule</a><br>	      
    	      </div></td>
    		<td><div class="sub_navigation"><a href=# class="main_link">test2</a><br></td>
    		<td><div class="sub_navigation"><a href=# class="main_link">test3</a><br></td>
    	</tr>
    no, go to the actual link that looks like this
    Code:
    <td width="19&#37;"><div class="navigation"><a href="../girls1.html" class="main_link">Girls</a></div></td>
    and replace it with this

    Code:
    <td width="19%"><div class="navigation"><span  onMouseover="submenu_girls.style.display='block'"><a href="../girls1.html" class="main_link">Girls</a></span></div></td>
    that should work, i know its confusing but i am able to answer any questions..

    as for the last on i have no idea why it is not hiding the table when over other buttons!!

    good luck!!!

  • #3
    New to the CF scene
    Join Date
    Feb 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Menu not working

    Thanks very much for the help! everything except the menu not dissappearing is working now.

    Jeremy


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •