Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Jan 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Newbie needs help with layout element (I think!)

    Hello,

    I have recently updated my website by adding some text in the left side via the header.inc file.

    Everything worked fine, with the exception of one page. I can't seem to be able to solve the problem on my own, and I'm afraid I may only confuse you if I tried to explain it (I'm not too comfortable with the html lingo). So I thought I may just post the link here and show you what is not working in the layout of one page. I should add that I did not edit the page in anyway, the layout changed as a result of the edit in the header.inc file, but no other page was affected.

    This is the page:

    www.aftersilence.org/about-aftersilence.php

    And for these of you kind enough to take a look, you will notice that an element of the background image (a piece of the two fingers that belong to the hand on top of the page) appears also at the bottom of the page, where it should not.

    I appreciate any suggestion you may give me in order to get rid of this annoying problem.
    Last edited by Winter27; 01-14-2008 at 07:45 AM. Reason: clarifying

  • #2
    Master Coder
    Join Date
    Dec 2007
    Posts
    6,682
    Thanks
    436
    Thanked 890 Times in 879 Posts
    Quote Originally Posted by Winter27 View Post
    Hello,

    I have recently updated my website by adding some text in the left side via the header.inc file.

    Everything worked fine, with the exception of one page. I can't seem to be able to solve the problem on my own, and I'm afraid I may only confuse you if I tried to explain it (I'm not too comfortable with the html lingo). So I thought I may just post the link here and show you what is not working in the layout of one page. I should add that I did not edit the page in anyway, the layout changed as a result of the edit in the header.inc file, but no other page was affected.

    This is the page:

    www.aftersilence.org/about-aftersilence.php

    And for these of you kind enough to take a look, you will notice that an element of the background image (a piece of the two fingers that belong to the hand on top of the page) appears also at the bottom of the page, where it should not.

    I appreciate any suggestion you may give me in order to get rid of this annoying problem.
    Make your markup valid first

    http://validator.w3.org/check?verbos...tersilence.php

    is first step, this will help you latter to fix the layout.

    check the css too

    http://jigsaw.w3.org/css-validator/v...tersilence.php

    best regards
    Last edited by oesxyl; 01-14-2008 at 08:09 AM.

  • #3
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,854
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    Instead of background="topmessage.jpg" write style="background:url(topmessage.jpg) no-repeat;"
    Also read Why tables for layout is stupid:
    Last edited by abduraooft; 01-14-2008 at 08:13 AM.
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #4
    New to the CF scene
    Join Date
    Jan 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by abduraooft View Post
    Instead of background="topmessage.jpg" write style="background:url(topmessage.jpg) no-repeat;"
    Thank you for the suggestion. Unfortunately, it replaced the unwanted element with a different unwanted part of the background image:



    Is there something else that I can try?

    Thank you.
    Last edited by Winter27; 01-14-2008 at 08:31 AM. Reason: +++

  • #5
    Master Coder
    Join Date
    Dec 2007
    Posts
    6,682
    Thanks
    436
    Thanked 890 Times in 879 Posts
    Quote Originally Posted by Winter27 View Post
    Is there something else that I can try?
    yes, validate!

    you have unclosed tags, abduraooft solution probablly solve the problem, but you can't see the efect.

    best regards


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •