Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Jul 2007
    Posts
    571
    Thanks
    25
    Thanked 28 Times in 28 Posts

    UL Background Wont Show in IE

    I thought I was past the days were I needed this form to help me with css but this has really stomped me!

    My page renders perfect in every browser except for IE because it does not show my background color or images for my UL tags.

    FF screenshot: http://browsershots.org/png/original...c4bd3f795a.png

    IE screesnhot: http://browsershots.org/png/original...d90bfa1525.png

    HTML:
    Code:
    <div id="sidebar">
    <ul>
    <li class="first"></li>
    <li><a href="<?php echo CONFIG_HOME_URL?>index.php">Home </a></li>
    <li><a href="<?php echo CONFIG_HOME_URL?>login.php">Login </a></li>
    <li><a href="<?php echo CONFIG_HOME_URL?>register.php">Register</a></li>
    <li class="last"></li>
    </ul>
    </div>
    CSS:
    Code:
    #sidebar ul{
    	width:210px;
    	margin:5px 0 5px -10px;
    	list-style:none;
    	background:red url(images/nav_bg.gif)repeat-y 0 0;
    }
    
    #sidebar ul li{
    	padding:1px 0px 1px 10px;
    	margin: 0 20px 0 0;
    }
    
    #sidebar ul li.first{
    	background:url(images/nav_top.gif) no-repeat 0px 0px;
    	width:210px;
    	padding-bottom:15px;
    }
    
    #sidebar ul li.last{
    	background:url(images/nav_bottom.gif) no-repeat 0px -10px;
    	width:210px;
    	padding-bottom:17px;
    }
    
    #sidebar ul li a{
    	color: #74623c;
    	background:url(images/sword.png) no-repeat 0 -33px;
    	margin: 0px 20px 0 0px;
    	padding:2px 0px 5px 20px;
    	font-size:11px;
    	text-decoration: underline;
    }
    
    #sidebar ul li a:hover{
    	background:url(images/sword.png) no-repeat 0 2px;
    	color: #1F0700;
    }
    Last edited by srule_; 01-09-2008 at 02:26 PM.

  • #2
    Senior Coder Arbitrator's Avatar
    Join Date
    Mar 2006
    Location
    Splendora, Texas, United States of America
    Posts
    3,274
    Thanks
    28
    Thanked 271 Times in 265 Posts
    Quote Originally Posted by srule_ View Post
    My page renders perfect in every browser except for IE because it does not show my background color or images for my UL tags.
    Educated Guess: url(images/nav_bg.gif)repeat-y

    Note the lack of space between the sub‐values.
    For every complex problem, there is an answer that is clear, simple, and wrong.

  • #3
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,480
    Thanks
    6
    Thanked 981 Times in 954 Posts
    Could it be the missing space between the image and the repeat?
    Code:
    #sidebar ul{
    	width:210px;
    	margin:5px 0 5px -10px;
    	list-style:none;
    	background:red url(images/nav_bg.gif)repeat-y 0 0;
    }
    … should be background:red url(images/nav_bg.gif) repeat-y 0 0;

    Without an online example it’s a little hard to guess, though.

  • #4
    Regular Coder
    Join Date
    Jul 2007
    Posts
    571
    Thanks
    25
    Thanked 28 Times in 28 Posts
    Thank you, I was over reading that! *darn typos*


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •