Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Feb 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Search box displaying but not working

    I'm trying to get Pico search to work on my page but while the search form is displaying correctly, you can't use it. The submit button isn't clickable and you can't type anything on the search box either. Can someone tell me what I did wrong? Thanks a lot!

    Code:
    <div id="header">
    <div id="searchform">
    <!-- Begin PicoSearch Query Box -->
    <form style="margin:0;" method="get" class="search"
    action="http://www.picosearch.com/cgi-bin/ts.pl" value="hidden" name="index" value="440030"/>
    <input type="text" name="query" value="" size="20" />
    <input type="submit" value="Search" name="search" /><br /></form>
    <!-- End PicoSearch Query Box -->
    </div>

  • #2
    Regular Coder
    Join Date
    Jun 2004
    Posts
    495
    Thanks
    0
    Thanked 82 Times in 80 Posts
    There are 2 value attributes in form.
    This is not the source of the problem, a link or complete document is required to track down the error.
    I suspect another element is overlayed over the form.

  • #3
    New Coder
    Join Date
    Feb 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I got it. I had to take the whole code outside the div layer. Thanks!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •