Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Sep 2007
    Posts
    27
    Thanks
    7
    Thanked 0 Times in 0 Posts

    can anyone tell me why my hover overs flicker in firefox

    my hover images flicker on firfx but work fine on IE also why is my site so split up and wrong on ie im working from a mac so cant view it in IE untill i launch it t http://www.juxdesigns.com/New/home.html .

  • #2
    Senior Coder
    Join Date
    Nov 2003
    Location
    Minneapolis, MN
    Posts
    2,879
    Thanks
    2
    Thanked 65 Times in 56 Posts
    Truthfully, it's hard to tell what's going on because the method you're using to get the navigation working is really convoluted (IMO, anyway). But you can get the links working better in FF by making sure the links, when hovered over, are block-level and have some dimension:

    Code:
    #home a:hover, #services a:hover, #portfolio a:hover, #info a:hover, #pricing a:hover, #theteam a:hover, #contact a:hover {
     display: block;
     height: 111px;
    }
    As far as IE, you'll have to change how the menu works because it doesn't respect the "display: inline-table" technique you're using.

    Hope this helps…


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •