Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    Daf
    Daf is offline
    Regular Coder
    Join Date
    Feb 2005
    Location
    East Texas
    Posts
    134
    Thanks
    30
    Thanked 2 Times in 2 Posts

    Mystery margin - seriously can't locate

    Hi all.

    On this page:
    http://www.ktbb.com/sports/hsscores.php

    (sorry about the southside ad - I can't remove it but I assure you I am not spamming that bank)

    Between the "Listen Live" section and the top of the scoring table (southside ad sit in top row of table) there is about 100px gap that I can not for the life of me find the cause/source of.

    Using the web dev tools I have disabled all styles and its still there. Viewing the source shows a column of <br> (not even the xhtml tags I use) causing the gap but what is causing the rogue break tags?!

    Any ideas as I am stumped on this one.

    css file is here:
    http://www.ktbb.com/css/main.css

    There is also a small section of block styles in head of page.

    Thanks!
    Daf

  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,853
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Blog Entries
    1
    Code:
    
    <br class="clear"/>
    <br/>
    <br/>
    <br/>
    <br/>
    <br/>
    <table class="scores"
    ??
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #3
    Daf
    Daf is offline
    Regular Coder
    Join Date
    Feb 2005
    Location
    East Texas
    Posts
    134
    Thanks
    30
    Thanked 2 Times in 2 Posts
    Right...

    The thing is that those break tags are not in the html document. That's the problem ... where are they coming from?

    I'm attaching the document, as a .txt file, so you can see pre parsing.

    Thanks
    Daf
    Attached Files Attached Files

  • #4
    Regular Coder ghostz00's Avatar
    Join Date
    Aug 2006
    Posts
    128
    Thanks
    11
    Thanked 2 Times in 2 Posts
    I would validate your code and fix the errors. you only have 8 but it might help. one of the errors was a <br /> after a </tr> on line 453. there's also a few others in the code too. I would clean that up and see if that doesn't help.

    http://validator.w3.org/ the site is very slow right now...
    Greg

  • #5
    Daf
    Daf is offline
    Regular Coder
    Join Date
    Feb 2005
    Location
    East Texas
    Posts
    134
    Thanks
    30
    Thanked 2 Times in 2 Posts
    Excellent call! Turns out there were 5 of those errant break tags within the tr tags - just the amount that were being inserted above the table. Fascinating behavior on the part of the browser to insert them there, albeit I failed in my task of telling it where they should go!

    The "paste" shortcut is very, very close to the "break" shortcut and my fingers are clumsy apparently.

    Thanks so much for the keen eye, ghostz00!

    I've also validated the page as well.

    Daf


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •