Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    New Coder
    Join Date
    Oct 2007
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Internet Explorer Image pushing past td cell in IE?

    I'm doing some contract work for a client, just slicing up and building a design that they sent me. It works fine in Firefox and IE 6 as far as I can tell, but in IE 7 the left and right sides of the top header images (the pictures that say "Production Canada") aren't lining up with the rest of the site by about two pixels. The left one seems to almost be pushing out overtop the table cell and the right seems two pixels short of fitting snug up to the side of the cell. The weird thing is that while they're not lining up with the table cell itself, they still line up fine with the menus and everything else.

    I've looked at the sizing of the images and td's as well as padding and even the silly IE bug where putting spaces in the code puts spaces in the layout (I had that problem earlier so that's why bits of the source code aren't properly formatted and all bunched up.)

    Any help or ideas would be appreciated, thanks.

    http://www.beans-etc.com/_test/

    (Please no comments about how this should all be in divs and not tables, etc. Tables is how I was told to build it by the employer, so that's what I did and therefore need it to work in.)

  • #2
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    This is how my PC sees the page with IE7

    I can't see what is wrong.

    Frank
    Attached Thumbnails Attached Thumbnails Image pushing past td cell in IE?-screenhunter_01-oct.-01-21.25.jpg  
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.

  • #3
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    Sorry! We found the following errors
    URI : http://www.beans-etc.com/_test/css/styles.css
    39 div.menu_nav Property _margin doesn't exist : -2px auto 0 auto
    109 div.menu_gallery Property _margin doesn't exist : -2px auto 0 auto

    Also has 37 html errors.

    http://validator.w3.org/#validate_by_uri

    Frank
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.

  • #4
    New Coder
    Join Date
    Oct 2007
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    This is how it views on IE7 for me: http://www.beans-etc.com/_test/screenshot.jpg

    I quickly circled the problem areas in orange, a two pixel gap or so on each side.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •