Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Sep 2007
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Menu problem with IE, but not Firefox

    Having just switched to a new server, my site's menu gets stuck in IE:

    http://www.hundredpercentgambling.com/

    If you mouse over the left side menu using IE, you'll see the problem - all the sub-categories, which should vanish after the mouse moves away, get stuck.

    If you run the same in Firefox, there's no problem.

    Anybody know the css (or java?) fix for this?

    These menus seem very twitchy in IE. This is the second issue I've come across where Firefox worked perfectly.

    Thanks in advance for any advice.

  • #2
    Regular Coder
    Join Date
    Jun 2004
    Posts
    495
    Thanks
    0
    Thanked 82 Times in 80 Posts
    This probably:
    Code:
    <!-- Begin
    startList = function() {
    if (document.all&&document.getElementById) {
    navRoot = document.getElementById("nav");
    for (i=0; i<navRoot.childNodes.length; i++) {
    node = navRoot.childNodes[i];
    if (node.nodeName=="LI") {
    node.onmouseover=function() {
    this.className+=" over";
      }
      node.onmouseout=function() {
      this.className=this.className.replaceĀ»
    	(" over", "");
       }
       }
      }
     }

  • Users who have thanked Fang for this post:

    guyd (09-17-2007)

  • #3
    New to the CF scene
    Join Date
    Sep 2007
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Fang, can you clarify, are you saying I should remove "replace", thuswise?

    this.className=this.className.»

  • #4
    Regular Coder
    Join Date
    Feb 2007
    Location
    Canada
    Posts
    924
    Thanks
    10
    Thanked 56 Times in 55 Posts
    Code:
      }
      node.onmouseout=function() {
      this.className=this.className.replaceĀ»
        (" over", "");
       }
    No, probably means find out what is causing this to happen

  • #5
    New to the CF scene
    Join Date
    Sep 2007
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks very much, folks. The fix worked fine, menu fully functional again in IE.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •