Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2

Thread: error 400

  1. #1
    New to the CF scene
    Join Date
    Sep 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    error 400

    Hi all,

    I'm pretty new to HTML and have been lumbering through trying to make a website for my employer.

    I'm getting an error 400 when i load the page sometimes. Also some images sometimes don't load on first go. Which requires reloading the page.

    My search has told me that error 400 and images not loading are related and could be put down to bad coding on my part. Which is no surprise really.. but i dont know exactly where i'm going wrong.

    this is the website im working on
    http://www.pesaropublishing.com

    and this is a another page where i have been experiencing problems like ive described.. there is very little code on this page so i was hoping that somebody might be able to look at it to see if anything jumps out at them as the problem that is casing the error and failing to load images sometimes.
    http://www.pesaropublishing.com/about.html

    thank you very very much for any help!

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Why doesn't your company hire someone who knows what they are doing?

    Anyways you have this on a few of your pages
    Code:
    <link href="../Documents/••Pesaro/•• website/text.css" rel="stylesheet" type="text/css" />
    <body bgcolor="#000000">
    </head>
    
    <body>
    It should look something like this
    Code:
    <link href="../Documents/••Pesaro/•• website/text.css" rel="stylesheet" type="text/css" />
    </head>
    
    <body>
    Notice how its trying to load a stylesheet from your own computer though you have the correct link to the stylesheet at the top of the page. Also on some servers filenames and file paths are case sensitive.

    You have this
    Code:
    <img src="../Images/Pesaro2.gif" width="473" height="53" border="0">
    but when viewing the image I get this
    images/pesaro2.gif, notice the capitalization?

    Finally you are using tables for page layout. Tables aren't meant to be used for page layout. I suggest you read the link in my sig titled "Why Tables for Page Layout is Stupid?".

    Also you should learn to use the validator. http://validator.w3.org

    It will catch all of your coding mistakes.
    ||||If you are getting paid to do a job, don't ask for help on it!||||


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •